Game Stuck on Splash Screen

BUILD #:** Unable to ascertain
OS:** Windows 10


When launching the game, I got stuck in start up screen


  • 100% of the time (ALWAYS)

Here’s the steps to reproduce the issue:

  1. Launch the game
  2. Wait
  3. got stuck
    4.try to stop it with steam, does not work


Main menu


it got stuck


Hey @XHartbox,

Can you upload your Age3Log file to assist us with tracking this issue?

Finding your error logs for Age3: DE Beta:

  • Open a File Explorer Window
  • Navigate to C:\Users\ “your computer username” \Games\Age of Empires 3 DE Beta\Logs
  • Locate the most recent Age3Log file

Age3Log.txt (255.0 KB)

Hi @Licidy,

I’m experiencing this bug still as well from the previous beta, attaching my log below.

Age3Log.txt (258.3 KB)

Thanks! We are tracking this issue on our end - we made some log-file configuration changes since the Stress Test which should aid in tracking this.

Another user indicated that the program F-Secure Cyber Security had blocked the game from launching, causing a similar issue. If you have this program, please try adding the game to its allow-list, and let us know if that changes anything. Thanks!

Thank you
I don’t have f-secure here, I checkt the local files through Steam.

Next step is I think is deleting the game and clean the files from stresstest?

Don’t have F-Secure on my system either. I previously tried disabling windows defender with no luck from the stresstest. I could try it again, but unlike the other user, @XHartbox and I don’t crash.

OMG. I got it! @Licidy, @XHartbox I was tweaking with the GraphicalProfile, adjusting the default values that were set for my system. I changed a lot and one of them let the game launch!

I tried to upload my tweaked profile but it won’t let me, I’ll attach a screen shot.

I know it wasn’t reducing the resolution to 1920x1080 and setting it to windowed mode…
I set a lot of the graphics options to 1 or lower, and I changed the refresh rate up to my monitor’s set refresh rate of 144. Disabled things like Bloom, streaks, high models and other effects.

I deleted the game and reinstalled it. The issue remains the same?

EDIT when I try to quit the game through steam it remains runnnig on the back ground

@Licidy I think I found the issue thanks to @agedmits posting the screenshot of his GraphicalProfile. I tried all the graphics changes he had and it didn’t help. What I noticed is that I was missing the final row from the GraphicalProfile file.

When I added the row false I was able to get past the splash screen. I was having this issue during the stress test and we couldn’t figure it out during that. Now I am able to get past the splash screen and into the game finally!

Thank You! @agedmits


@Licidy @agedmits @XHartbox For some reason I typed out the code in the previous reply and it didn’t show. I’ll attach a screenshot to show the row I added that fixed the problem. I circled the row in Red. Please let me know if you have questions on what I did.

1 Like

where do i find these settings?

found it but still got stuck as before

Did you add the line that I circled and saved the file?

yes i did ad the line and saved it.

I now deleted the game again, I’m going to wait for the 15th when the game comes out. Big disappointment

@XHartbox, if you are willing to try one last thing, it could be a collection of graphical issues or slightly different for all of us. Adjust your file to match the one that I posted above. It worked for me when I changed several of the options.

@agedmits thank you you persisted it was the resolution setting for me

1 Like