Game will not launch and has been uninstalled - Unable to install it from the Store

Hi, i’ve been feeling your pain for a few days now. Exact same problem and I tried all the fixes.
I solved it by finding a permissions issue.

I tried downloading it to c: and also d:
in D: i found a windowsApps folder I couldn’t access as it was trusted installer permission or something.
I managed to change permissions to this folder (found by searching newly created folders when I tried to install on D:)
once I changed folder permission I deleted it.
When I installed the game again it surprised me by getting pat 281.4MB… and it’s the only thing I changed since the last failures
I haven’t completely downloaded it yet but thought I’d share given the frustration I know it causes.
Good luck

I fixed the issue using a VPN. I’m in Australia and I set the VPN to the USA

It could be on another drive and/or be hidden, I can’t remember exactly how I deleted it, think I followed the instructions from a search result of “windows apps folder get permissions”, this gave me access to the “WindowsApps” dir, then I use icacls to fix the permissions, this then allowed me to delete the dir.

I’m in europe so probably using the german servers for downloads already.

I ended up with “Error 0x80070780: The file cannot be accessed by the system” when attempting to delete it. It’s the only folder in WindowsApps that’s unaccessible for me.

Poor fella! Hope you get everything working again asap and someone helps you.
Shabbat Shalom.

So my game randomly decided to come back by itself and is working fine now. Didn’t have to do anything. Game was gone for one week; did sfc, dism, chkdsk but everything was fine.

This worked for me. Thank you so much! I spend so much time to solve this Problem and Nothing worked. But this was the solution - for me.

1 Like

Worked for me also - thanks. How do you know that? Impressive

Hey everyone reinstalling gaming services through powershell worked
For those of you who are looking online my error code was :
Something unexpected happened
Reporting this problem will help us understand it better. You can wait a bit and try again or restart your device. That may help.
Code: 0x87E00017

Solution for this: Reinstall gaming services

  • Launch powershell as an administrator and enter “get-appxpackage Microsoft.GamingServices | remove-AppxPackage -allusers”
  • In the same powershell window, enter “start ms-windows-store://pdp/?productid=9MWPM2CQNLHN”
    Attempt to install just AOE2DE after Gaming services is installed.
    Hope it helps to those out there