Game will not pass intial loading screen

Hello Community,

I have purchased AOEIV and was hoping to play the game however it seems the game has other plans for me.

I have tried to start the game multiple times and I never get past the initial loading screen with the rotating circle and glistening map.

I have restarted my PC multiple times, verified my game files, deleted every file in the directors in my documents folder and nothing seems to work.

My PC is well above the minimum required specs and I do not know what to do, so I have come here for some assistance.



Have you tried temporarily unabling your anti virus program?

I had sort of the same problem with aoe3 DE. That was caused by the anti virus program blocking aoe3. If that’s the case you can add the aoe4 exe file to the list of excluded files in your anti virus program.

Otherwise you can also look if the firewall is blocking aoe4.

Hope it helps!

Hey mate, thanks for the advice. Once I excluded AOE4 in my antivirus it allowed me to run the game without issues for now, hopefully, it stays that way.


No problem, glad to be of help!