General Campaign bugs

Game Version:

  • Build since release
  • Platform Steam


I’ve played a few campaigns since release. I’ve noticed there were and still exist some bugs that could be easily fixed. Obviously i can’t cover them all since haven’t played all the campaigns yet and maybe can’t recall some of them now. I’ll mention some:

  • Dos PIlas
    One of the first major breaking bugs is in Historical Battles scenario Dos Pilas, origianlly released with the forgotten expansion (not very surprising). At the start of the game you control Dos Pilas city and need to advance to Castle, once this is done or some time passes, purple sends some army and once they reach you need to decide whether to join purple or orange. If you choose orange you need to reach another town to control with some units and then defeat purple. You can also take back Dos Pilas (now yellow) by destroying its town center… or that’s what supposed to happen. For some reason you take immediately control of Dos Pilas again, and now you are with 2 towns. This may happen because the yellow town center is destroyed/doesn’t spawn and that counts as taking it back and your town center respawns. Odd thing is when you look at it before it becomes yours you see like 3 towncenters stacked onto another but that maybe only virtually (irc that also happened in HD, but it wasn’t broken). The worst happens next. For some reason purple sends again army and again you choose who to side with and if you choose orange again you now lose both towns as they become yellow (enemy) and again you have to send those units to the 2nd town, but now that’s impossible because the gate won’t open. Haven’t tried to destroy the gate to see what happens , nor do i plan to. I chose once to side with pruple and nothing happens at least at first, i didn’t continue to see.

  • Manzikert
    the byzantine AI doesn’t seem to know what to do and once i took pisidia it was tried to attack my buildings there and just stuck its small army with ram right below the cliff just trying to attack it, instead irc it should just go straight to my camp.
    Also galatia seems to have its gate locked and if you take it over w/o destroying the gate (now possible in DE with siege tower) it remains locked, had to destroy it with onager. Just make the trigger to unlock the gate if it is not destroyed

  • Genghis Khan
    The most notable i remember is on the 2nd scenario, a life of revenge where u need to kill Kushluk. Again the AI probably didn’t know that apart from a trigger where he runs away the first time he sees your army, but then suddenly i won by sending a few pikes and realized Kushluk just saw them and attacked… and died, making the scenario very easy.
    Also on the 5th scenario. the promise, where u fight poles, germans and bohemians and just need to capture flags, as mentioned by another forum post theres a gap in a cliff where after cutting down trees units can just pass which i noticed myself and didn’t reemember till i saw the post (idk if this is patched or not).

These are the ones i encounterd and remember, im pretty sure there are more like those, especially in the forgotten expansion ones since they were already too buggy, read a post about Honfoglalás that scenario doesn’t move on when all enemies killed or something, but i haven;t played it yet in DE.


Came to look for the Dos Pilas bug, can confirm it happens exactly like this.

Yeah, hero units sometimes just charge at your units or base for no reason. In Genghis 2 I realized that Kushluk is just attacking my base by himself while I was still in the middle of destroying the last base.

The cliff gap bug you mentioned is something I’ve ran into too numerous times, namely in Genghis 5 and Barbarossa 5. In Barbarossa 5 there is a part where you have to fight a few bombard cannons and cavalry near a cliff after cutting trees with your onagers. Those guys can just walk through the cliff and attack you now.

1 Like

Can confirm that Honfoglalás is bugged, the winning trigger didn’t work for some reason. The scenario required the player only to defeat 2 of 3 main enemy to win, but nothing happened after that.

I killed the remain enemy also switched enemy stance to a blue player (a friendly NPC), defeat them, none of the players left so I won.

1 Like