Grass looks like Anti-aliasing is not working

The grass and farms crop looks like there is no Anti-aliasing,
although it’s on high, anyone else experience that?

Is that how they made the game, or I have some kind of bug on my system?
It’s pretty ugly to be honest, AOE 3 looked better…

5 Likes

So no one knows how to fix that?
Tried to play with nvidia drivers and set it from there, but still the same.

Actually with and without AA I don’t see any change, only the FPS is affected.

My bigger issue was how smudged and blurry all the buildings looked. Removing antialiasing made the buildings look great but of course the grass is super pixelated. I’ll take that trade until the devs fix it.

My grass is pixelated either with AA on or off, I couldn’t make the grass look good no matter what I’ve tried.

Just turn off the Anti Aliasing off and it fixed my issue.

can we see some before and after pics? if youre fine

It’s hard to see in the pictures @Latulevieja but when the grass is moving it’s extremely pixelated in both settings.

Without AA:



With AA:


2 Likes

Late to the party but, with nvidia control panel antialiasing transparency setting to supersample x2, and without much hit on gpu use, it seems to have been fixed the issue for me, which was most noticeable during camera paning and looking at the grass (FLICKERING). Rest of antialiasing are disabled (nvidia and in the game), and playing at 1080 with 24 inch monitor.

2 Likes

No no , its a bug on some systems . The game on 4k honestly looks good.

1 Like

how does it look , can you send me a photo?

Pixelated grass usually is caused by either running a non-native monitor resolution (say, play at 1440p on a 4k monitor) or because you have scaling set to anything other than 100% in the graphics settings.

The way this game handles resolution scaling is extremely bad and the grass and farm crops suffer the most for it, I’m guessing because anti-aliasing is not applied to them or otherwise performance would tank (there’s grass everywhere)

Of course @ 4k it looks good because it approaches “retina” levels, which is to say that the eye cannot tell apart individual pixels, so you can even get rid of anti-aliasing altogether.

Can’t seem to solve this and I’m beginning to wonder if everyones gaslighting me into thinking the game looks different on other computers. I mean, does grass and foliage really look this bad? The only solution so far is upscaling the game to 4k… But, that shouldn’t be necessary.

image

In fact, the Anti-aliasing options in the game DO work, just not for foliage. Heres wishing anyone has a fix after a year.

3 Likes

Same problem here, do you have a Nvdia card?

Yes, an RTX 2080 to be specific.

I have also heard others tell me that they don’t have this issue. Although I’m unsure whether they actually do have the issue (but aren’t paying enough attention to note it) or if they actually don’t have the issue, and that it might be related to my system or files.

It’s weird.

I have this issue on a 3090. You can add transparent anti-aliasing via the Nvidia control panel to help smooth out the foliage aliasing, it works-ish but is performance impacting. Maybe Relic can dig into this issue.

So I have tried this in the past and found it to not work, so I tried again today and it seems you need to set your Antialiasing to at least High before fiddling with Transparency for it to have any real impact whatsoever. The results below show some experimentation with Low, and no Aliasing.

Here is an image with no Antialiasing at all.

NoAA

Here is one with Low AA and 4x Transparent-AA in the Nvidia Control panel.

AAandTransparency

And here you have a comparison of the game up-scaled to 4k.

4k

Setting it to high and changing your transparency settings to 2x or 4x does somewhat help the foliage. Though like you stated, that is a lot of bruteforcing just to get to the foliage–and it does not actually smooth it out as much as I would want. There is also an issue of flickering when in motion, making it seems pixelated in motion. AoE3DE has Temporal Aliasing which works great for their foliage, I wonder if this could be added to AoE4.

EDIT: Also despite my images, the issue seems a lot worse zoomed out than in, making things look more pixelated.