Heavy FPS drops while playing Multiplayer

Game Version:

  • Build (101.101.35209.0 4667120)
  • Platform (Steam)

Issue:

Hey guys!
Following problem. I bought this game to play multiplayer against my friends. When i start a Multiplayer-Game, the FPS drops from about 500FPS to constantly 14-15. If I start a game offline, i can play with 500FPS. Each friend playing with me have the same issue while they´re in the same game as i am. Funny fact, if I start a Multiplayergame and disconnect my wifi adapter, the FPS jumps up to 500FPS and when i connect it again I get my 15FPS again. I have no idea what to do anymore.

I reinstalled it, updated my grafic card,…

Maybe someone knows how to solve it. I also noticed that the problem is known by a few players but i never saw a solution.
Thanks,
Richard

2 Likes

Got similar issue; MP games locked somewhere between 15-20 FPS, SP is fine and watching recorded games or spectating “live games” is fine aswell.

Having this issue since beta, I can fix but some updates make issue arise again. What I do to fix it is to restart in safe mode and use DDU (3rd party software) to uninstall both GPU drivers. Yes I do use both GPUs (trough 1 HDMI) for powersaving and heat management (as some laptops do). Then restart in normal mode and disable temporally Windows update, download and install both drivers again.

After it issue is gone but I really dont understand whats causing it or what is fixing it really :scream:
Here a list of my specs if thats helps.

|OS|Microsoft Windows 10 Pro N|

|CPU|QuadCore Intel Core i5-6600K, 4200 MHz (42 x 100)|

|MOTHERBOARD|Gigabyte GA-Z170M-D3H (2 PCI, 2 PCI-E x16, 1 M.2, 4 DDR4 DIMM, Audio, Video, Gigabit LAN)|

|Chipset|Intel Sunrise Point Z170, Intel Skylake-S|

|System memory|16296 MB (DDR4-2133 DDR4 SDRAM)|

|GPU1|GeForce GTX 1060 3GB (3 GB)|

|GPU2|Intel® HD Graphics 530 (1 GB)|

|NETwork|Intel® Ethernet Connection I219-V|

1 Like

Hey mate!
Thanks for the reply!
Thats pretty much to do especially if you are not that familar with the in deth of your computer.
Is there any chance that a patch will fix this?
Greetings

Ah, so it wasn’t just us…

Three of us were playing on a Ludakris map the other day. Which is something we’d done before without issue. But this time, when there were only two enemy forces left… the game just started tanking. Even when it was just down to one AI (against three of us), it became downright unplayable.

Our rigs are all quite past recommended specs, and again, we’ve been running the game perfectly fine until now.

what about this developers? can you reproduce this as well?

I’m having the exact same issue. When I’m not in a multiplayer game I get high FPS, as soon as I join a multiplayer game the FPS get stuck at 15. I tried the game in another computer in the same network and it’s working fine. I’m not sure what’s going on, I’ve updated the drivers and nothing. Low resolution doesn’t change a thing. It’s weird that’s only when in multiplayer.

Experiencing same issue.

@AnimalFeline275

so in the same network its working? you think it´s possible to create a virtual network(for example via Hamachi) with your friend and play the game? Would be a current solution.

Greetings

An update, I tried in another computer and at first it seemed fine but eventually it all went down, same FPS issue. I tried using my 4G network and it also had problems.

So I tried something else, I created a multiplayer game through the lobby, only me and an AI and guess what, same FPS problem. There’s definitely something going on with multiplayer, so frustrating…

I really wonder if it isn’t possible to get an official statement on this? Like if any developer can reproduce this or is working on problems like that?
If it’s only a problem with very special systems and it won’t be fixed forever then we at least know about it.

yeah, copy that…

If you guys have spare time and knowledge to do so, try a fresh installation of windows 10, this solved the issue for me too, again, no idea whats causing it.

2 Likes

I did that today, now everythings fine here as well. THX :blush:

oh wow haha, i hope i don´t ruin something by reinstalling windows. Thanks for the tipp mate

After reading SorcerousBoat7 who fixed that with a clean window instal i tryed a less destructive approach.

Instead of installing a brand new windows, i created a new windows user account.
Then i ran the game under this new user account. Guess what, no fps issues anymore !

To avoid having to manage two windows sessions i did the following things (you migh have to adapt if your are not using the steam version)

Since steam complain if we directly try to start game through the executable, and since you can’t tell steam to run a game under a particular windows account, i decided to run steam under this particular account.

To make things a bit simpler, you can make a script for this

  • create a new file named xxx.bat where “xxx” represent the name you want to give to your script (ex: steamLaunchForAoe2De.bat).

  • Paste the following code in the file

@echo off

taskkill/F /IM steam.exe
C:\WINDOWS\System32\runas.exe /savecred /user:useraok “E:\Jeux\steam\steam.exe”

Taskkill line quit steam if it’s allready started.
The next line retart steam under the freshly created windows account (useraok in my case)

Replace the text in the file according to your needs

  • /user:useraok -> replace “useraok” with the name of your new windows account
  • “E:\Jeux\steam\steam.exe” -> replace this with your own steam executable path

When i want to play the game, i execute the bat file to make sure my steam is started under the fresh windows account, then i run the game via steam library.

As a result, you can see that the game run under those new credential.

Hope it helps some of you.

3 Likes

nice man, thanks! I will try it out!

Olala No help me :frowning: