Heavy GPU usage after patch

:arrow_forward: GAME INFORMATION

  • GAME BUILD #: 44725
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED

After the recent update, when starting any game (skirmish, campaign, multiplayer, spectating multiplayer) the GPU usage goes up to 90%. Does not apply for menues.

:arrow_forward: FREQUENCY OF ISSUE

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

Here’s the steps to reproduce the issue:

  1. Start any match or campaign
  2. Open task manager and check for CPU and GPU usage (it is also audible)

:arrow_forward: EXPECTED RESULT

Regular GPU usage.


I have experienced the same issue. I have like 200 fps but my laptop gets very hot.

Many people have same problems, some posted here, some on Reddit as well. This needs to be resolved for sure, otherwise many people will be without they CPU and GPU :smiley:

Yes, good to hear. I thought it was on my end and updated my GPU drivers but the issue persists.

Problem is not on your end, but on games end, they did something wrong and need to find out what is the reason for this problem. So, we just need to hope they will sort it out soon.

1 Like

Same issue over here. And because the high GPU and heat build up my laptop shuts itself off after a while.

Same problem here. Ever since the new up-date the game crashes after 10-15 min in game, regardless of mode. And when I open task manager, it runs over 90% usage. I’m frustrated. Event uninstalled and reinstalled the game. Was so excited for the DLC and now I can’t event play a single match.

Same issue, my machine is not high spec although it was OK to play previously and since the change it is impossible to play, it stops working after a few minutes… freezes play, music continues GPU stops and CPU remains on max. eventually it says not responding and then sends report to microsoft. Hopefully resolve soon…

1 Like

Same problem here, 2070S goes to 100% and full fans when playing when before was around 30-40% only and quiet.

1 Like

A solution offered by the team is to enable the “Vsync” setting in your graphics options. This should lock the game at your monitor’s refresh rate, thus putting less pressure on your GPU or CPU as you play. Please let me know whether this changes the behavior or if you continue to see issues after doing so—either way I’ll be passing the information along to the team!


Yes, This reduced the GPU load to back to 30% and FPS fixed to 60 FPS (before I was getting like 500FPS)

Yep, same issue for me. I hit over 1000fps today: https://www.reddit.com/r/aoe2/comments/l6b9d7/ever_wish_you_could_run_aoe_at_over_1000fps_with/

Edit: vsync has worked for me, now locked to 60fps and GPU is significantly quieter and cooler

Certainly the score and fps increased with this patch, but even with vsync and 75 fps locked, the gpu is still noisy, even if the load is minimal and the 0 rpm profile enabled.

It only happens in game, in the menu everything is normal.

Hi, I’ve just tried this and it has made no difference: the game still crashes within a couple of minutes of starting any match. Menus work completely fine, but once I start a game, CPU and GPU still go wild almost immediately until the game stops responding. Music still plays but the image is frozen.

1 Like

Same Problem here, hope it gets fixed ASAP

works like a charm, thx

Nope, same problem, few minutes in and CPU goes made and GPU stops and freezes video, sound carries on…