Help: AOE4 absolutely will not update and I can't play online

I play AOE4 on PC from game pass. For some reason, I absolutley cannot get it to update and as such cannot find an online match. I will literally sit in queue for 20+ minutes with no match found. I’ve tried everything I can think of to force it to update: uninstall-reinstall, verifiy and ###### the check for updates button in the xbox app, the updates page in the microsoft store library, everything. No idea what I should do. Please help!

I am having the same issue. I am on game pass ultimate for pc. When browsing the community servers, none show up at all. There are none in the observe tab also. MS Store says I have latest update. I have forwarded the ports on my router also.
Is this an issue with AOE4 on game pass?

So I am on gamepass and no multiplayer games are showing up at all. Latest version.

Can anyone help out here?

I would honestly try to just reach out to microsoft support at this point, it sounds like you did your due diligence and tried to troubleshoot as best as you could. Since no one has replied in awhile besides others who are having this issue I would say to just reach out to them if you havent gotten it fixed already.