Help Installing the December Update

Hello, it’s January 8 and I have not received the December 17th (34055) update in the Microsoft Store. I’ve even tried Windows Update. I’ve also posted in the Age of Empire Forum


You say you tried to update, but did it really get up to date? I believe that to currently download and install apps from MS you need to have version 1903 or above to Win10. You can check that at Win Key + I > Settings > About. Under the ‘Windows Specifications’ section should be your Win ver. If it is not version 1903 or above you can update it with the official Update Assistant from Microsoft.

Aside from problems updating AoE, can you download/update any other app from MS currently?

Have you also tried to follow the official recommended steps to update?


Thank you for your response, but I had followed those steps previous to this posting and I had upgraded to version 1909.

P.S. my other apps update with no issues e.g. Office 365. Thanks again.

Hey, a new update arrived today. If you still can’t download it, could you provide further explanation about your issue? What you’ve told so far still kinda vague.

Here there’s also some more tips to deal with common download issues.

Sorry for the late response. Appreciate your assistance.

I understand the December 17, 2019 download was to be found in the Microsoft Store. I did not get the download. You also indicate there has been a subsequent download, I haven’t received that one either.

The version of Windows 10 I have is 1909.



I see there has been another update/hotfix as of 1/21/2020 version 34699. My AOE II DE is version 33315. There have been five updates/hotfixes since then. 34223, 34055, 34397, 34483 34699.
I’ve followed all the steps: going to the Micorsoft Store, clicking on “updates”. Now, I am getting Microsoft Store updates, but nothing concerning AOE II DE. My Windoow 10 version is up to date (1909). What do I need to do now?

Sorry to hear that :frowning_face:. Since MS got no detection on DE when yout ask it to check for updates and none of previous methods worked also, I can only think to suggest you to reinstall the game. I’ve seen no simmilar report around, and can’t think of any other workaround to deal with it. What seems to be is that the directory in wich the game have been installed got lost from MS somewhere along the way.

This is ironic, after my post. I did some more research on this issue. In doing so, I read that I should navigate to the Library in the Microsoft Store. I opened Installed under Library Saw AOE II DE listed along with other apps. I decided to click on"launch". I navigated back to “Downloads and updates”. AOE II DE was now included under Available Updates with two other apps. Naturally I downloaded them. I now have version 34793 with the Lunar New Year Event on the title page.

So now it seems that I am up to date.

Thank you for your help

1 Like

Of course I’m assuming that version 34793 contains all the previous updates.

It is the build up to date. I’m glad that it is working now, enjoy your time playing!

But DARN, why Microsoft Store is so troubled??