Heroes bug

I had experienced problems with heroes and some special units in some campaign mods like Mehmed The Conqueror and Apranik. Some weeks ago, heroes habilities and attack and armor bonuses were correct but now these bonuses are gone. They lost their attack and armor bonuses, like the Sipahis. This was a change made by Game’s stuff? Anyone else has experienced the same problem? There’s a way to fix it? Thanks in advance.

Hey, it’s funny it’s me replying to this particular post since I happen to be this campaign’s creator :smile:

Anyway, yeah that’s not specifically tied to Hero units, it’s simply the current Modify Attribute bug, it affects the whole game, every scenario (official or custom) that uses the Modify Attribute effect to tweak attack/armor values in whatever capacity.

It will only be fixed with the next official patch, along with many other game-related issues.

Now, unfortunately for you, this scenario will prove SUPER hard to beat without the Siphis at their intended strength. So i would recommend to wait for the next official patch to carry on if you want to experience the campaign in its full experience.

It’s kind of frustrating but nothing can be done in that regard at the moment.

On that note, I’m impressed if you managed to beat the siege of Constantinople with the bugged Sipahis!

Thanks for playing anyways!

Ahhhhh. I see. When we will see the next official patch update? The campaign is difficult without sipahis super habilities. The second scenario I needed to use all my qualities to pass it. But I will play it again when the bug is solved. Thank you so much for the campaigns, I hope u will do more in the future. I suggest a phew ones:

-Byzantine-Persian Sassanid wars

-Jan III Sobiewski

1 Like

The fix patch was supposed to be released last week, but they reverted to the previous (bugged) version after experiencing serious performance issues. So far no further information has been given.
Maybe sometimes next week we can hope for something?

1 Like

I hope they will fix this bug soon. We need Modify attributes back! Thank you for the answer. I will let open the thread until fix is resolved.


Hey @MLC8896, bug’s problem was resolved?

This should be fixed with the last update.

The Modify Attribute bug is solved indeed.

There are still bugs in the editor that haven’t been addressed yet though.

If you find new bugs that haven’t been reported, please let us know :slight_smile:
Thank you!

1 Like

Yes, I confirmed the Object in Area bug yesterday, haven’t checked for the others yet.


1 Like