Hold Against the Horde: The Rise of Moscow Campaign

Upon finishing the initial hold against the horde when the game autosaves it lets me continue on for a brief moment on the next phase of the campaign mission when I am tasked with defending Moscow while the villagers flee. However, when this starts the game ‘skips’ twice and then closes, no crash error or anything, just closes. This is where I am stuck at and I cannot continue. I have only tried restarting my PC as far as troubleshooting goes. Any help would be appreciated.

Upon reading other threads I see some issues may be related to ‘updates’ with the game which I do not know anything about. Everything on my PC is up to date and I run the standard windows defender, which may not be related at all to this issue.

Thank You
Very Respectfully

Sorry you ran into this @Amunra2668! Next time you have a crash/unexpected close, please contact support here with your DxDiag and warnings.log file. It’ll help the team sort out why this might be happening.

Thanks so much!