Horrible Performance Issues

I have an unusual gaming setup I admit, but there’s no reason it shouldn’t be able to run Age of Empires: Definitive Edition at least as well as computers 20 years ago could run the original.

I have a Razer Blade Stealth QHD+ i7 7500U thunderbolted to an external NVIDIA 1070. I understand that this makes my GPU heavily reliant on my CPU, but I have absolutely no problem running more modern games including GTA V and Call of Duty Modern Warfare at 4K 60fps. The fact that I can’t at any resolution, with any amount of tinkering eek out more than 20fps from AoE:DE without having it drain my laptops battery faster than the wall can charge it is totally ridiculous.

I’d imagine this has to do with the devs building this game using the same rendering code as the 20 year old original, but what do I know? I’m just a dumb player.

The point of this rant is twofold: to ask for serious help from the developers in making these games (including AoE2DE) run as easily as possible on all machines, which I’m shocked they don’t already, and to provide a stern warning that these games are not going to fare well if released as an unoptimized mess.

I’m open to any suggestions if there’s a known fix, but from what I’ve read so far the universal fix is to request a refund. I don’t want it to come to that. Please devs fix this game.

2 Likes

What does task manager display in performance tab when running the game? Could you screenshot and post please.

Whoops this is the picture you actually wanted

So your GPU is having a lot of trouble. Do you have the GeForce Experience game driver installed?

Running at 100% while playing games is normal for GPUs. I have the most recent drivers but bloatware like GeForce Experience will not make a positive difference.

No it’s not for that GPU. I use a GTX 950 Strix it runs at 35% on AoE 60fps
[Edit] hmm I always thought it was bad to operate at 100%. Don’t really know what’s wrong otherwise, also GeForce Experience is a gaming driver not bloatware

The game is using 100% of the single CPU thread that it is running on. Because you have a 2 core CPU with 4 threads that comes down to 25% in windows task manager. If I am correct you will see the performance get choppy as you move around the map fast by holding down right mouse button and GPU utilization drop as you do so.

The current crossplay client is badly optimised and untill they fix this pushing down the resolution as low as you can will increase performance. This is because the game is 1-to-1 pixel sprites and it limits the amount of objects the engine has to manage. So put the game into smaller resolution and see if that helps.

Is the game single thread only?

So is my low fpson zoom detailx2 zoomed out due to RAM or CPU?

Yes the game is single thread only, the game engine is from the '90s.

Just to cover all areas turn off Virtualization and see what happens

Umm the other pic is his system

In your case ninja, your CPU is running in powersave mode for some reason(it’s below the 3,5GHz base clock). That’s probably why you’re not getting higher FPS.

But I can’t know if it’s the game not asking for more CPU processing power or if it’s windows not giving it to the game. All I can say is check your power save settings.

1 Like

Lowering the resolution brings me to another weird issue, even at 640p I’m only getting 30 fps as if it’s locked, even though I have it turned off in settings. Zooming out even at that resolution still lowers it to <20 fps.

Would turning off hyperthreading be the solution here?

Turning off hyperthreading is never a good solution, it causes performance issues in everyday use.

Instead you can manually limit the process to a single core when it’s running through Task Manager Details tab:
-> Find the AoEDE.exe -> right click -> set affinity -> untick cores 0,1

This will tell windows to only allow that process to run on the second core(which should be mostly free of other programs, like windows interrupts) and it should stop juggling the process between cores. If you wish to try simulating multithreading off, you can also untick core 3(or 2) so it will only run on a single thread. These may or may not help depending on a multitude of things.

Well I always thought I had it on best performance but when I checked it was on better. Thanks, I’ll try the game out later ^^. Could changing what core the game runs on add some better performance as well?
[EDIT]
Didn’t seem to do anything, max CPU was 3.20GHz averagely.

Unfortunately, nothing has had any affect, even lowering the resolution.

After setting the game to high priority in task manager, I could get 60 fps right when starting a game, but as soon as something moves the fps drops to 30 and then eventually 20. 7 or less if I’m not all the way zoomed in. At this point I think this is entirely to do with the programming, there’s no reason I should be getting such horrible performance so consistently.

On a side note, I noticed that the main menu only ever runs at 20 fps, so whatever is happening in the game is happening throughout the game.

I pray to god these issues don’t carry over to Age II DE.

Same issue in age 2 DE.

1 Like

Is there anyway to disable the “icy” navigation (when you press the arrowkey then stop theres a 100ms delay before it stops, this didn´t exist in aoe II HD).

i have same issues with an GTX 1080, high GPU usage very low fps, this issues are only in aoe1de in aoe2de i do not have any issues