Hot keys not working as they were before the latest patch

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: #810058
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED

:point_down:I had hot keys assigned for 5 through 0 for "selecat all " buildings. ie, 4 = Select all Markets, 5 = select all baracks, 6 = select all Ranges, etc… These functioned perfectly well before this latest patch. I would select “6” and then could que units from ALL RANGES, so on and so forth. Now, since the latest patch, I select any one of the previously set of numbers and nothing gets selected. I tried resetting all fo them from scratch using a “mock” hot keys profile to no avail. Please Help.*

:arrow_forward: FREQUENCY OF ISSUE

:point_down: Continual.

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

  1. Hotkeys/Game commands/“select all XXXX”
  2. Assign a number from control set to corresponding select all production building.
    3.Test this assigned number in game.

:arrow_forward: EXPECTED RESULT

:point_down:Prior to latest patch… (not numbers of number pad, but top line of keyboard numbers) select 4, then all markets were selected, select 5, then all barracks were selected, 6, 7, 8, 9 & 0 all had “select all” buildings assigned to them. This worked GREAT for lategame spamming of units.*

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.

:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe2spgame) or GAME RECORDING (.aoe2record) of the match where you encountered the issue. Link it below if using an external file service.


Hi @GrizzlyBob8584
The problem with adding these hotkeys to numbers is that it clashes with control groups. I reported a similar issue a few days ago, but it seems that with the new implementation of the hotkeys features “this issue was fixed”, I mean that using numbers as something different than setting control groups was some kind of broken before, that’s why you could use them. I’m sorry but you are gonna have to set new hotkeys different than numbers now :frowning:

So in order to “fix” the game, it gets made worse. Just like “fixing” the pathing. Everytime they"improve it" it functions worse. Seems to be a theme with in game fixes. They function worse after the “fix”. SMH

So there is a fix to this!!! I got it to work, as it did before. Therefore, I do not have to find/learn different hotkeys. I just find it quite upsetting to hear, no you cant use 1-20 for anything else other than setting control groups in game ONLY. It’s a waste of potential hotkeys, as I only use 1-3 for setting/changing control groups in game, why not assign the other ones to maximize efficiency? Just my opinion. And sorry for the frustration. Thank you.

Hi! I was experiencing the same issue and found a solution: you can reset the select group hotkey to none, so when you assign the hotkey 3 to all stables for example it will work
Captura de pantalla 2023-04-13 155405