Hotkeys and singeplayer settings reset to some default on every game restart

:arrow_forward: GAME INFORMATION

  • GAME BUILD #: version 82587 (latest)
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED

Every time I open the game, my hotkeys reset to the default aoe2DE hotkeys. The “hotkey profile” name shown is blank. I need to choose my hotkeys from the drop down menu every time i open or restart the game (the whole game, not the match).
A similar and probably related issue is that the match settings in single player always reset to a coastal game of berbers VS celts. If i play a different settings match and then open single player again, it will default to the last settings played. However, closing and openning the game will still reset the settings to those arbitrary settings.

:arrow_forward: FREQUENCY OF ISSUE

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

Here’s the steps to reproduce the issue:

  1. set the game’s hotkeys to any profile.
  2. close and re-open the game
  3. Watch your hotkeys profile now and see it has been reset.

:arrow_forward: EXPECTED RESULT

my hotkeys should not be reset to the default profile upon openning the game.

:arrow_forward: IMAGE

:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe2spgame) or GAME RECORDING (.aoe2record) of the match where you encountered the issue. Link it below if using an external file service.

an FE dev commented with a solution on reddit: Reddit - Dive into anything

There was probably a broken user configuration file somewhere. Renaming the profile folder and letting the game create a new default one fixed it. I then had to copy my saves/scenarios/replays to the new profile folder and re-configure my settings.

1 Like

I’m glad you solved it :slight_smile: