Hotkeys Changed and Cannot Change them Back due to Insufficient Space

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: AOE II DE, Version 101.102.18071.0 (483607) 11179620
  • GAME PLATFORM: Steam / Microsoft Store
  • OPERATING SYSTEM: Windows 10 / Windows 8 / Windows 7 / Mac / Linux

:arrow_forward: ISSUE EXPERIENCED

My hotkey for my towncenter, and many other hotkeys were changed and I did not change them. When I tried to fix it, it will not save the correct hotkeys, and I get this error message:

“There was a problem writing file. Additionaloptions.aop due to insufficient space. Please delete some files.” My hard drive has lots of space available, so I do not understand this. I cannot play the game without hotkeys.

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

  • Less than 25% of the time / matches I play (RARELY)
  • 25% of the time / matches I play (SOMETIMES)
  • 50% of the time / matches I play (FREQUENTLY)
  • 100% of the time / matches I play (ALWAYS)
    100% of the time.

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

  1. As soon as I load the game, and go to hotkeys, it has been changed for my towncenter (most importantly) and many other hotkeys. For towncenter it shows as Extra Button 1 on my mouse.
  2. Try to change the hotkey back to H for Town Center and click confirm.
  3. Gives you error message stated above.

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?
I would be able to play with my desired hotkeys. I cannot play the game without my hotkes.

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.

:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe2spgame) or GAME RECORDING (.aoe2record) of the match where you encountered the issue. Link it below if using an external file service.

This is another error message that I get.

I reported this issue to the team, in the meantime, I recommend you to try setting the hotkeys back to default to check if you still get this error message or not.
Thanks for your report.

Hi, I tried to change the hotkeys to default, and I got the same error message. I definitely can’t play like this. Thank you for your attention to the matter. I browsed the forum and it seems this is happening to other people as well. See attached error message for when I tried to use the default hotkeys.

1 Like

FYI my hotkeys still are not working. I have a theory about what is happening though. I play this game more than most people, and my steam account says I have played 3637 hours. On steam, when I go to properties, for my steam cloud, for Saved games, it says I have 95.37 stored, and 809 bytes available. I was not aware there was a limit on game saves or capacity. I think my hotkeys may not be working because I have too many saved games. Screenshot attached.

I deleted all of my hotkeys and it still says my cloud is 100% full. The error is on the cloud, and that is what is stopping me from changing my hotkeys.

Bump. Please see my other replies. I think I know what’s wrong. The issue is with steam.

Are you on Windows OS?

Windows 11. PC info below:

Edition Windows 11 Home
Version 22H2
Installed on ‎10/‎23/‎2022
OS build 22621.1702
Experience Windows Feature Experience Pack 1000.22641.1000.0
Device name BT_Mantis_PC
Processor 12th Gen Intel(R) Core™ i9-12900F 2.40 GHz
Installed RAM 64.0 GB (63.9 GB usable)
Device ID DB284444-C469-4D1F-9385-9514ECFE30B0
Product ID 00326-10121-48887-AA954
System type 64-bit operating system, x64-based processor
Pen and touch No pen or touch input is available for this display

I don’t think this issue is related to Steam Cloud, I can recommend you to try some stuff:

  1. Deleting your user files. For deleting your user files, you should:

a. Make sure that your Steam Cloud is disabled in Steam, AoE2 game, Properties, General.

b. Go to C:\Users\YOUR_USER\Games\Age of Empires 2 DE.

c. Copy your user folder to a safe place, it has lots of numbers.

d. Delete the original folder

e. Verify your files in Steam, AoE2 game, Properties, Local Files.

f. Open the game again. A new user folder will be created.

If this works, then copy back the files from your old user folder. Those files are in the folder -C:\Users\YOUR_USER\Games\Age of Empires 2 DE<0>\Savegame, Recorded Games and Save games.

1 Like

I did the steps you said, and it worked! My hotkeys are still messed up, but at least now when I try to put the hotkeys back, it allows me to save the changes and I do not get the error message anymore. Thank you for your help and all your work on this game.

Update: When I turn off everything in Steam/properties/general, I am allowed to change my hotkeys. But when I put all the options back in the General section, then I get the error message again. I do think the problem is with steam. Also, I delete all my saved games, and both AOE 2 says am at 100% capacity on steam, and steam itself says I am using pretty much 100% of my capcity with only a few bytes available. How do I clear data from steam that it is storing?

I’m afraid there is no way to delete the data stored in the cloud :frowning: