Hotkeys - Combining Control Group and Unit/Building Selection on the same hotkey, with single and double keystrokes respectively, fails to work for double keystroke keybind

When using a single hotkey (for example ‘M’), for both a “Control Group” (single keystroke “M” keybind), and “Select All [Building Type]” (quick double keystroke “M [x2]” keybind), the double keystroke action fails to take effect, and results in selecting the control group instead of switching to the double keystroke selection.
Note: This extends beyond just “Select All [Building Type]” hotkeys, and fails for other hotkeys listed later.

The purpose of this example keybinding is to subselect desired Markets with a single keystroke, and select all Markets with the double keystroke, using a single hotkey.

  1. Set “Select Control Group 0” to “M” keybind (single keystroke keybind)
  2. [Optional] Set “Set Control Group 0 to selected unit(s)” to “Ctrl+M” keybind
  3. [Optional] Set “Add Selected Units to Control Group 0” to “Shift+M” keybind
  4. Set “Select All Markets” to “M [x2]” keybind (quick double keystroke keybind)
  5. Build 2 or more Markets
  6. Select some (not all) Markets and add to Control Group 0
  7. Press “M” hotkey, and the previously selected Markets put in Control Group 0 will be selected as desired
  8. Press “M” hotkey twice quickly, but the desired “Select All Markets” keybind fails to take effect, leaving only the Control Group 0 Markets selected.

This keybinding setup fails for the following combinations:

  1. Assume that you have “Select Control Group 0” set to the “M” keybind. (Doesn’t need to be Control Group 0 or ‘M’ keybind)
  2. Put some units or buildings into Control Group 0.
  3. Set “M [x2]” to desired selection hotkey.
  4. Attempt the “M [x2]” quick double keystroke keybind.

Setting “M [x2]” to ____ fails to select:

  • "Select All [Building Type]"

Setting “M [x2]” to ____ fails to select and has “Camera Side Effect” explained below:

  • "Cycle Through Individual [Building Type]"
  • "Select All Villagers"
  • "Select All Idle Villagers"
  • "Select All Idle Military"
  • "Cycle Through Idle Economic Units"
  • Other “Select/Cycle [Unit Types]” hotkeys

Exception! Setting “M [x2]” to ____ works!:

  • "Select All Units on Screen" works.
  • "Select All Units" works.

Camera Side Effect:
In Settings → Controls → Scroll down → General section, there are camera effect settings such as “Follow” and “Select and Center Camera” for selection/focus hotkeys.
For the examples above with a “Camera Side Effect”, even though the selection ultimately fails, and leaves you only selecting the Control Group 0 units/buildings, the camera moves as if the “M [x2]” hotkey did indeed take effect and work, centering the camera on the villagers/military/whatever. It seems the game enacted the hotkey properly, but then immediately after, the control group hotkey activated again (erroneously). This somehow worked correctly for the exceptions above.

The game might be doing the following and failing to select properly:

  1. Receive “M” keystroke, select Control Group 0.
  2. Receive a quick second “M” keystroke, activating “M [x2]” keybind, selecting units/buildings from the hotkey, and maybe moving the camera based on settings.
  3. Game erroneously also sees this as another individual “M” keystroke, activating the “M” keybind again, selecting Control Group 0 again, which breaks the intended effect of the “M [x2]” keybind to select something different.
    This might not be why the hotkey fails, just a potential way it might.

Final notes: I didn’t test every possible hotkey using “M [x2]”, but I did try some, and actions like “Reset Camera” worked as intended. This would primarily be messed up for selection hotkeys because the “M [x2]” gets overridden by the Control Group 0 selection.

Build: 5.0.15965.0

If this was already fixed on the PUP, which I didn’t try, I will be sad that I didn’t need to write this up.

1 Like

The only way it works is: select control group 0" in M, and go to control group 0" in Mx2.

the way you do gives a conflict: M selects group 0 and you want Mx2 to select the markets, it gives a conflict, it is not possible. I use x2 to not activate the button by mistake but that does not allow to use that button for x1, greetings

Note: it is the same in the pup

Thank you @CrackingMusic84! Really, really, appreciate the thoroughness here! The team will check it out.

Thank you as well @HasanIchess.