How do I download mods manually on the website?

Hello!
CONTEXT:
So here is why I am asking my titles question. I cannot download any mods ingame, the download never starts. The same is with the event mods. All the picutres are blacked out and only the border is golden of the ones I unlucked and the same with the regular mods, the download wont start and I everything I try to subscribe to does not appear in the “subscribed” page of the game. It also doesnt appear in my aoe2 mod folder.
(Here is a problem why Im asking this) BUT everything I subscribe to ingame (or on the website) does appear to be subscribed on the website (but there is never a download).

EXAMPLE
So basically I can subscribe to “improved smaller tree mod” and it wont appear ingame or in my folder but it will appear to be subscribed on the official website.

But what does work? Putting the mod manually in my “local” subscribe folder.
–thats why I need help–
I tried googeling how to download any mods manually on the official mod page but it only tells me to “subscribe”. There is never a download happening.
If anyone is curious. Yes. I did contact the support, but after a back and forth and trying mostly everything except connecting to a new pc the support gave up and told me to ask on the official forum if anyone can help me with my question on how to fix it or how to download mods manually since they dont know how except clicking “subscribe”.

THE QUESTION:
Is there a page or a way to download the mods manually on the website so I can drag and drop them into my local subscribe folder?

Sadly no.
Have you tried to repair your game install ?

yes. basically everything from verifying, reinstalling, deleting the mod folder, unsubcribing from the mods on the page, resubscribing ingame and out of the game. Nothing works.
I havent played in 2 years and just came back then everything just broke.

There is no way to download them manually? Damn. I might be screwed unless someone else sends me the mod files… that sucks

Go to the mods folder and in the mods josn file change every instance of true to false. Unsibscribe and subscribe again. If that doesn’t work, I can send you the files

I think I forgot to mention it.
I have atm 2 working mods “small trees” and “zetnus improved grid mod” these are also the only 2 mods working. I have some other older mods I backed up earlier (which worked before) in my mod folder as well but they are not working anymore after I tried deleting the game file on my computer (tried to full wipe everything but backed up the data before to see if there is any change)

I have no problem enabling and unsubscribing to mods which are shown in “installed mods” . At the moment there are only 2 installed ones. But I cannot install any additional mods (apparently… dont know.)

this is in my mod-status file: {“Mods”:[{“CheckSum”:“1810375879”,“Enabled”:false,“LastUpdate”:“1670279287003”,“Path”:“subscribed//790_Small Trees”,“Priority”:1,“PublishID”:0,“Title”:“Small Trees”,“WorkshopID”:790},{“CheckSum”:“3701668084”,“Enabled”:false,“LastUpdate”:“0”,“Path”:“local//812_Zetnus Improved Grid Mod”,“Priority”:2,“PublishID”:0,“Title”:“Zetnus Improved Grid Mod”,“WorkshopID”:0}],“Unsub”:[]}

(I changed the true to false as you requested but nothing changed except for the 2 working mods to be enabled (I can just reenable them) but I still cant download additional ones or subscribe ingame to any of them with any visual indicator of it working)

there is only one file called “info” in my mod folder which has:
{“Author”:“”,“CacheStatus”:0,“Description”:“”,“Title”:“Zetnus Improved Grid Mod”} this in it.

I have no idea about coding. Hope that information helps?

Send me a PM and I’ll send you the files.

how do I write a PM here? :slight_smile:

click on his name and then on Message →
Screenshot 2023-07-07 194342

Oh, I think I know why it isnt working. I created this microsoft account today/yesterday and it seems new players cant message other people. Probably spam protection.
My steam and discord name are the same as my username if that is okay for you. And btw, thank you for replying. It is just a bit frustrating since I know this problem I have wont be fixed in the future ._.

1 Like

image
that is how it looks for me

as a side note, this is how it looks ingame for me if we just talk about the event mods

pressing subscribe will lead to a loading symbol and then it stops. Trying to download it from the achievement screen (where you can see all the challenges) leads to an endless loading screen.
Trying to subscribe from any mod in the search function leads to the loading symbol for 2 seconds and then it stops with no effect