I cannot join the multiplayer services

After the July update i have started to take this problem again. Is there anyone working on it

1 Like

Hi @UglyMagician89, The July Update hasn’t been released yet. Have you tried the troubleshooting steps below?

Yes, i have. Here is a screenshot of the issue

. Also thank you for responding so fast.

1 Like

is multiplayer down at the moment?

It is down for me. I cannot join multiplayer games in DE while i can play other online games.

chicos que tal que hacemos ? es por la actualizacion o por que es? alguien sabe? no tengo ningun servidor

I restarted the game a couple of times and it worked maybe try that until there is a fix?

It doesn’'t work. I have been trying since the update.

If you are still having this problem, check in C:\program files(x86) if you have a folder called “AOE URL Helper”

What if I DO have it?

1 Like

Delete folder, open game, you probably can’t connect to multiplayer, close game, restore the folder and reopen game. Might fix.

still nothing, even after the server maintenance can’t log in

still having the same issue. @RadiatingBlade do you have any other suggestion?

no puedo conectarme con los servidores, estaba en plana partida y me sacaron

Have you had this problem fixed for you? I have the same issue.


I was just able to update and start playing the game after a month where I did not have WiFi. When I updated the game, I found that I was not able to connect to the multiplayer service. I’ve gone through the troubleshooting section and tried all of those steps. It still has not solved the problem. I’ve tried multiple different WiFi and that did not help it either. Is there any other people who had the same problem and is there anything I can do to solve the problem. I have also uninstalled the game and reinstalled it and that didn’t do anything.

tengo el mismo problema y no encuentro solucion

Sometimes it is just: Try again, but it seems like that doesnt works for you.

Yeah, I even tried deleting/reinstalling steam before installing aoe2 de again. I know it worked for me just last month and it is really frustrating for it not to work now.