I can't play cooperative campaign


Do you still have this issue in the last update?

For me, I didn’t get the issue now, but because we already have made multiple times the Coop campagns so we didn’t tested it recently.

But my friend got something similar with the last update, only one time :

  • He hosted a multiplayer game with me (2p+6AI, unranked/normal game/MEGARANDOM)
  • We played it fine and beat the AIs
  • After this game, he tried to do the first campagn of the new DLC (Devapala 1) : He got the AI error.

Yesterday he tried to launch directly after starting AOE2DE the Devapala 1, the scenario launched correctly.

I will try to launch a coop game tonight to see (also in previous patches, the AI error was occuring with P2 as an AI and also as a human).

Thank you so much, let me know how it goes ^^

Hi !
I tried everything to try to get the bug, but I can’t reproduce it so it seems good !

I tried :

  • Launch multiplayer game
  • Then launch coop : Fine
  • Launched campagn in SP
  • Launch coop : Fine
  • Launched multiplayer game : fine too !
  • Launched SP then coop : Fine :slight_smile:
1 Like

My game is doing the same. I am playing on Xbox game pass and my partner is doing the same. She can load that campaign and it is fine but when I host the map fails to load. This happens for any online campaign.

Which error appears Wh1tty? Do you have a video?


I’m having exactly the same problem. I can’t host a coop game with my brother. I always have “err5001”. When he hosts, everything works fine.

I have no mods, I run Windows 11 and Steam. My brother runs Windows 10 and Steam. I tried erasing and reinstalling the game, deleting the Age of Empires 2 DE folder in the user folder, checking the files integrity, rebooting.

I remember being able to host coop games. The problem started at some point during the previous months. Maybe when I upgraded to Windows 11, or with some Age II DE update.

Here is a screenshot of the error message.

Hi @Wachouff !

Do you have antivirus or other programs that could interfere with the game?

Can you add the game to the whitelist in those programs? C:\Program Files (x86)\Steam\steamapps\common\AoE2DE is the default, AoE2DE_s.exe is there.

Let me know if the problem is fixed!

@Wh1tty If you can do the same as explained above it could be nice ^^


Thank you for your time. I only use Windows 11 standard’s antivirus, with the preset settings. I’ve never tweaked it. I’ve added the exclusion. I’ll tell you if it’s fixed next time I play coop, probably next saturday.

Unfortunately no luck. I disabled my firewall and failed and then added permissions but still no joy. I can play online still but not create my own, It only works if I join someone else’s game.

Thanks, I share this with my team ^^

It still doesn’t work after tweaking the antivirus.

1 Like

It still doens’t work. I’ve tried several things, and it really looks like an in game bug.

Hi everyone,

The current PUP has additional tracking methods. Could those who still run into this issue try the game using the PUP and add LOGSYSTEMS=AI VERBOSELOGGING to the launch options?

If the issue reproduces, close the game and send us your log files found here:
C:\Users***\Games\Age of Empires 2 DE\logs

Thank you!

@Wachouff @Wh1tty Have either of you still been experiencing this bug? if yes have you guys been able to get any logs for us to look at?


Does this works with the last update ? I will try some coop tonight.

With last version of the game, for the moment the bug is not present with some tests !