I can't play online

:arrow_forward: GAME INFORMATION

I have a problem that does not allow me to play online, and also usually blocks my internet connection in the process. It doesn’t only happen to me playing AOE-3 DE (because it also happens to me with other games), but I hope you can help me here in some way. Thank you.

  • GAME BUILD: I start the game, and when I try to play online, the image that I will post below appears, and also my internet appears as “disconnected” when the connection is actually stable. When I close the game my connection is reestablished.

  • GAME PLATFORM: Steam

  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED

Unable to play online, and lost connection when trying to do so.

:arrow_forward: FREQUENCY OF ISSUE

100%

:arrow_forward: REPRODUCTION STEPS

  1. The game started.
  2. Tried to go online
    3.What has already been mentioned happens

:arrow_forward: EXPECTED RESULT

I should just be able to play online

:arrow_forward: IMAGE

:arrow_forward: GAME FILES (SAVE / RECORDING)

It seems like something related to the IP or the firewall from what I’ve investigated on my own, but I haven’t found a way to fix it myself.

Please help. I don’t know what’s really happening. I have the same problem again even though I formatted my PC.

I don’t know if it’s a problem with the game, with Steam, with my IP, the firewall or the internet service provider, but any suggestions would help me track down the problem.

Make an xbox profile and log in using that inside the game.

I’ll try. Thank you.

did it work, just curious.

No, it didn’t work, because the game disconnected my internet.