I can't play usa dlc

hello, i need same help, how can i pl;ay usa if i buy it? when i go in library i see the game but when i enter in gam,e i cant play with them,

1 Like

how can i pl;ay usa if i buy it?
The same way as every other civilization in the game- by selecting it from the civ selection list.

when i go in library i see the game
What library, Steam library? This is a DLC, not a game, it’s not visible in the ‘library’ listed on the left as a separate product.
To check if you have it click on the AoE III DE, and on the right in the main window there’s a small DLC segment, click on ‘Manage My X DLC’.
It should be on the list. If it’s not there- you don’t own it and have to buy it:

If you own it make sure blue checkmark is visible next to it. Without it DLC won’t be enabled and civ might not be accessible.

If you bought it and it is enable- make sure all downloads are complete. It might take a moment. You can restart Steam if there are any issues, but there is no sale event active at this moment, servers work fine.

i have the dlc, i enter in dlc game and i see is instaled, but in game is locked


We are aware some users are locked out of the USA DLC. We apologize for this inconvenience and our team is working on it. For the time being, players have seen success in disabling the Steam beta build in their settings, which has fixed this issue for them. Please try that and we’ll let players know when a fix is available.

Greetings Maxy

Look, dlc is enable but in game…

So when you try to select it there’s something like a lock icon on the flag?

I don’t know exactly how it works, but there’s some authentication going on in the background.
Few universal things you can try:

  1. Restart Steam client.
  2. Verify integrity of gamer game files. Click RMB on the game from the list on Steam and click:
    Properties…LOCAL FILESVerify integrity of game files…
  3. If you are not doing that- log into your Microsoft account (on the main screen click on a button in the upper right corner, next to the avatar). If you are logged it- log out and log in again. It might trigger something.
  4. Wait. Especially if that’s a fresh purchase. I remember few times saw people with similar issues for various things. Just wait hour or two and check again.
    DLC works fine 100%, something is just not registering properly.

Hello, why i can’t play with usa if i buy the dlc on steam?,when i enter in library i see de the dlc, also i have the dlc instaled when i press on aoe 3 but in game i can’t ude them…if the problem is not solved in 2 days, i want my money back and also i will refound aoe 3 bcs is a shit if you cant use the dlc

How i do that? Bcs i dont know

Same shit problem…it’s rly anoing

I press check integrity of files, but i have same problema…i can’t play usa

I have the same issue, I played the us civ before now its missing, I did verify the files, steam beta was already disabled, and reinstalled the game, and the DLC checkmark is on

Look, mexicans work with our problems

Then you probably do not have it enabled
Give them some time, they are working on fixing the issue !

I have this problem as well. I’ve tried ALL suggested solutions online. I tried verifying my files. I tried reinstalling. I’ve rebooted steam and my computer multiple times. I completely removed all mods. I tried removing and replacing the user files where the save data is stored. I even enabled and disabled steam beta just to humor the idea that it might work. Nothing works.

As you can see I have a custom city name so I definitely have been playing USA before.

I have contacted official support. It unfortunately seems we’ll just have to patiently wait for them to fix this issue. I miss planting my flag on the front lines and my gatling guns mowing down infantry… :pensive:

que raro me parece todo esto, y parece ser que solo afecta al DLC de USA mmm en mi caso cuando salio el evento para tener gratis a USA lo gane y la obtuve gratis y mucho tiempo despues, cuando salio Mexico me compre el DLC de USA y no me salio nunca un error parecido con ningun DLC y eso que tengo mods

its without a doubt related to that unlock period, almost seems like its messing up purchases with people that didn’t unlock for free, translation, something is wrong with verification on this particular dlc since last patch

Me and my brother do not have access to USA now. Hopefully they get it fixed soon