Installed Mods are just not working

Game Version:

  • Build (101.101.33059.0)
  • Platform (Steam)


The mods that I installed and enabled do not work.

Reproduction Steps:

  • I browse for mod (e.g. small trees)
  • I subscribe it and wait till downloaded
  • I can enable it on the “installed mods” tab
  • When I start a singleplayer game, there are no small trees

Did you closed and opened the game again to let them be applied?

yes sure I tried that

I have an idea what it could be.

The thing is that the button “open directory” in the mod manager does not work either.

Could that be because my path to the mods contains spaces and also a “ü”

1 Like

having the same issue. can’t get any of the triple tech mods to work. Though the mod that changes the main menu to night time works.

The same for me, installed and enabled, but do not work!

For the “Small Trees” mod for example, the game creates the directory:

C:\Users\ “Username”\Games\Age of Empires 2 DE\76561198084277495\mods\subscribed\790_Small Trees\resources\ _common\drs\graphics

…but it is empty of files! Shouldn’t have something inside “graphics” ? There is only an “info.json” file, in the “790_Small Trees” folder, that seems irrelevant anyway.

The button “Open Directory” in the Mod Manager does not work as well.

Never mind, I’m dumb. I forgot you have to select the data set mod when choosing the options for the match.

I have non-latin (Greek) script Windows username and I face the same problem; “Open directory” button doesn’t work nor any mod.

Despite the patch note:

“Fixed various issues caused when installing the game to a folder with a path that utilized non-Latin characters”

… I have to report that nothing changed, at all. In order to make the thing work, I was forced to rename my Windows 10 user folder, using latin characters (a process that involves registry edit, no good).

After that, mods and “open directory” button work.


I also have this Issue, maybe because I have a é in my username.

Hello there and merry christmas!

I registered today because I could install the 2019 Winter Celebration Mod, it says it’s activated (red exclamation mark), but when I start a random map or a campaign, there’s no winter to be seen! Everything looks normal.

Am I overlooking something?

I bought the game recently via Microsoft Store and play on PC. The Link to the Winter Celebration Mod came from

Please help, I would love to fire presents at my opponents!

I am also having this issue, I have the game itself and steam stored on my D drive and not on C, do not want to move it to C, and have heard that can be the issue due to the mods being installed into C drive, is there a fix for this??

I have searched for a known fix but cannot find anything… help???

Now that you mention it… I installed the game on Volume M:. I can’t even move it to C: cause C is an SSD and does not have enough available disk space.

Could you maybe copy the Mod directory to your game path?

Is it correct that the Winter Mod has just one file? It showed just one when I opened the directory.

It has 178 files in 8 folders (nested)

OK… then why does it just show one on the ingame browser when I click “Open dirctory”?

I just migrated the game to C: The button that says “downloading” is grey at the same time, so I don’t know if he actually IS downloading or not, because there is no other way to check the progress. Or do I have to quit the subscription, uninstall it and start the whole thing again?

Sorry, but I’m totally confused. On the web page of the mod, there seems to be no download button and the ingame mod browser appears to be broken (or so I read). Would be great if you had any clues?

Unpack this to local mods till mod manager is fixed. “C:\Users{username}\Games\Age of Empires 2 DE{userId}\mods\local”

Wow, thanks a lot! But what is my user ID? Thing is, I have two folders containing a folder called “mods”. One is named “0”, the other has a very long number, 2535439285745023. I guess the last one’s it, then?

Yes. “0” is for offline like I have heard.

1 Like