[Issue] Mods not working and downloading properly on Steam version

Game Version:

  • Build: (101.101.32911.0 4395365)
  • Platform: Steam
  • Win 64

Issue:

Whenever I select mods they do not show up in the standard game and are not downloaded.

So I installed this game at launch and I have been trying to play the game with a few mods. For example, I would like to play on a forest nothing map with x9 tech mod or something. But the mods are not activated correctly and are not downloaded properly. In this image:

, you can see that I have selected and activated a few mods. However, when I try to select the map in the custom scenario, it doesn’t show up.

When i select the mods in the “Browse mods” tab, they get an “!” before them in the “Installed Mods” tab. Then when I hover over the mod it says downloading, but it never stops downloading. If I then relaunch the game, I get what you can see in the picture, but the files are not downloaded. I also tried to just let it download for a few minutes but it doesn’t seem to download anything.

Furthermore, when I go to the folder on my PC with the mods (C:\Users###\Games\Age of Empires 2 DE###\mods\subscribed) , I can see the folders with the mods to which I am subscribed to. But when i open the folders, the actual files needed for the mod to work are not there, there are only the info.json files there.

And I don’t know if it is part of the same issue or not, but whenever I try to click the: “Open Directory” buttons in game, it doesn’t open the folder in Windows (not even in admin mode), while the “More Info” button does work.

Steps I have taken to try and resolve the issue:

  • Reinstalled the game, first it was on another drive but now it is on my C drive
  • Subscribed to the mods in game as well as on the website, and being logged in in the game with the same account (Microsoft account)
  • Installed the Xbox Console Companion app in Windows, like one of the mods in the Discord suggested
  • Deleted the folder with the mods in it, and started the game in admin mode
  • Verified game integrity
1 Like

having the same issue. I’ve tried everything. The mod that changes the main menu to night time works but I can’t get any of the triple tech (or more) mods to load and that’s the only mod I care about

Edit: can’t get it to work in Windows store version of the game either. I give up

i’m dumb. I forgot you have to select the data set mod when setting the options for the game. I was able to get it to work

Is this still an issue for you in build 101.101.33315.0 4426672

Did you happen to buy the game on both steam and xbox live?

Have you tried deleting the whole mods folder, and not just the subscribed folder? Sounds like a permissions issue, or that security software on your machine is blocking it. Might also be a specific mod with corrupt files or too long file names.

Side note: I always knew forest nothing to have closer trees and to be an rms, not a scenario.
Which is why I made this one:
https://www.ageofempires.com/mods/details/1228/
Not sure why the other has so many downloads.

Thank you for responding, I just tried and it is still an issue . I only have the Steam version so I only know it from happening on that platform.

I tried deleting the whole mods folder, starting Steam in admin mode, disabling my firewalls and virus scanners, all while running the xbox console companion app. I try to just use the dark main menu and small trees mods as these are the most popular and most widely used. The issue is just that I can select a mod from the mod browser tab, subscribe to it, it begins downloading but it never stops, when I hover over the mod it just says downloading the whole time. It doesn’t matter if I let the game run for 30 mins it just won’t download properly. I mean it creates folders and it downloads the mod.json file just fine, but it won’t download the specific file needed to execute the mod. For example the small trees mod creates the folders: resources, _common, drs, and graphics but each of them is empty. When I restart the game, instead of a red exclamation mark beside the mod I could now enable and disable these mods, however even after a restart of the game, these do not actually enable.

What I also tried is to download for example a random map script, like forest nothing (my bad for saying it’s a scenario), and installing it manually and that works just fine (even if the rms is from the HD version). Unfortunately I can’t find the mod files to manually install some of the mods.

I find this all very weird because like you said it does seem to be a permission issue, but if disabling my firewalls, virus scanners, etc. and launching the game in admin mode don’t solve it then I don’t know what will. Maybe if i do a clean install of the game and delete all the local files it would work, so that is something I could try.

Well you’re not alone on the downloading issues.
https://forums.ageofempires.com/search?q=download%20category%3A102
I don’t have any problems myself.
I know small trees works, haven’t tried the other.
I’ve wondered if long windows user names could cause issues, like 60 characters long, hopefully people aren’t that silly

One of the forest nothing’s up there is a scenario and I’m not sure how people use it or why it’s popular.

If I think of anything else I’ll let you know.

I posted a response here that might help
https://forums.ageofempires.com/t/can-t-download-or-subscribe-any-mod/64534/11

But I can’t just copy paste it because “it’s too similar to a post I made recently”

Thanks again, I indeed have a special character in my user folder name (ë). However, it seems it is not really feasable to change that name without a complete reinstall. But maybe I could create another account, download the mods there and just copy paste them.