Issues still present

Hello everyone, I am writing this post to make a list of problems that, in my opinion, should still be solved to make the game playable at 100% of the possibilities and above all to have a smooth gameplay experience. I also wonder if some problems I encountered in game have been encountered by other users or not.

Main issues:

  1. Hitboxes: Isn’t it frustrating to see a greedy castle from the enemy and not be able to hit his villagers because of the too large and inaccurate hitboxes? Don’t tell me about the patrol machine, as the patrol also automatically attacks buildings and that’s not how the game is supposed to work.
    Also, it is often very difficult to click on the right tree in a woodline, due to interference from other hitboxes.

  2. Pathing and Stuttering Units: Certainly some steps forward have been made, in the sense that the knights with the defensive +2 do not die against an equal number of crossbowmen, but I still see melee units that instead of attacking enemies nearby and in their line of sight stand still and allow themselves to be killed, despite the use of aggressive stance.
    For the pathing, villagers and units continue to make strange paths allowing themselves to be easily killed for it.

Secondary issues:

  1. Not so smooth HUD: I often find myself having control groups overlapped during my games. Like “15 knights on control group 2 moving to control group 3”. I think I understand what happens; while I move the cursor and click down to move in the map, the HUD “is dragged slower than the view”, remaining in the position it was previously and consequently I also involuntarily click on the + which moves the knights control group to the number next (from 2 to 3, for example).
  2. Canceled Imperial Age Research: I have lost some games due to the canceled Imperial Age research.
    And it has happened too many times to believe it is just an unfortunate coincidence.
    This could be due to the above problem; probably the HUD is so unresponsive and “reactive” that deleting villagers in production from a tc involuntarily ends up also canceling the imperial age research.
    In summary, we could say that the problem lies in the slow and unresponsive interface (for example if I search for a hand cart wrongly, I will have to wait 2-3 seconds to see it reappear as research available in another TC)
  3. “Fallacious control groups”: I am recently using building specific control groups to play in MQ instead of SQ like I used to do on Voobly.
    For example: I set 5 to select all military buildings, 6 to barracks, 7 to archery ranges and so on.
    Sometimes, however, it happens to have in control group 5 also the TC (although I have not selected it) and some military units (therefore both military buildings and units), and it is very frustrating as I no longer have a way to correctly use this functionality in that specific game and there is no way to “deselect” everything during the game

I hope I have given some useful feedback to the developers (and I hope I have not got the wrong section) I would like other players to tell me their opinion about it!

PS: Edited the post with the 5th issue


This is a tragedy. How come would this happen? I have experienced the above 3 but not the last one.

I cannot speak to the secondary issues that you mentioned; however, I definitely have been experiencing both of your main issues.

  1. Hitboxes - This is one of the most annoying (imo) issues in the game. When an enemy is attempting a castle drop in your or his own base, it is imperative you are able to quickly task your units to attack the villagers building the castle. I cannot count how many times my units have attack the castle foundation instead of the villagers behind the castle - wasting precious time that could have prevented the castle from getting up.

  2. Pathing and Stuttering Units. Yes, just yes. Above all else … Please fix this.
    I don’t know how, but I believe that the pathing was better in the original CD version of the game, then the state the path-finding is now. This is my one ‘fly in the ointment’ with the DE version of the game.
    Seriously, if this was fixed, almost all my griefs with the DE version of the game would be solved.


For the Hitboxes issue, you can use ALT + right click. ALT ignores buildings for unit commands.


I think the secondary issues are just a HUD issue. I’m pretty sure of this (maybe I’m wrong, but still…)

1 Like

I’ve heard of this solution, but why should I press one more button if it would be enough for me to be able to click the mouse in a specific place?

1 Like

Did not think of that, Thanks @Harooooo1 !

I’ve heard of this solution, but why should I press one more button if it would be enough for me to be able to click the mouse in a specific place?

@Atmosfear2982 I would agree with that line of thinking as well, especially since before DE, it was something that wasn’t a problem.

1 Like

Same thought, don’t see why I should “relearn” the game instead of playing it as I usually do


Yes I agree with you both. But this is the best thing we have so far, even if not ideal.