Jan Zizka campaign: Malevolent Marauder achievement bug

:arrow_forward: GAME INFORMATION

  • GAME BUILD #: 51737
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED

Achievement “Malevolent Marauder” doesn’t unlock even after destroying all 6 Bohemian villages in Jan Zizka campaign scenario “The One-Eyed Wanderer”.

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur?

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

  1. Load the first scenario “The One-Eyed Wanderer” in the Jan Zizka campaign.
  2. Destroy all six Bohemian villages. You will get a dialog from Jan Zizka “I despise the slaying of innocents…” when you successfully destroy each village. Both objectives “Conquer local settlements” and “Destroy local economic buildings” will complete. The player “Bohemian Villages” will also be defeated.
  3. Despite fulfilling these criteria, the achievement doesn’t unlock.

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?

Achievement “Malevolent Marauder” should have unlocked when the required criteria is met.

:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe2spgame) or GAME RECORDING (.aoe2record) of the match where you encountered the issue. Link it below if using an external file service.
Zizka1.aoe2spgame (588.7 KB)

The savegame provided above is just before the last village is destroyed. The two remaining buildings (Trade workshop and lumber camp) needs to be destroyed to complete the required secondary objectives to unlock the achievement.


Had the exact same issue


I also had this issue, I even collected all the cows (so all mission objectives complete) and it still did not fire


I have the same problem. I don’t get the achievement

1 Like

Yep, I have the same problem. Tried multiple times with different ways to complete the objective. Does not work.

1 Like

Same here. And the achievement “Protector of the Realm” is bugged too.


Yeah, “Protector of the Realm” also needs to be fixed. Did you have any problem with “No Quarter” achievement?


I also had this issue although it showed up as completed in my xbox account. So on steam I don’t have it but on xbox I do.


Same problem here, played it twice and didn’t work

1 Like

same issue here… makes me think i shouldnt bother with achievements until a month or so at least

1 Like

Hi everyone, the issue is being looked into, thank you for your reports!


Have the same problem with this achievement and also Protector of the Realm. Just retried the Malevolent Marauder one even destroyed every single bohemian village building but won’t pop. Does unlock on Xbox though so yeah…

1 Like

Same problem with this achievement – I also cleared out all farms, houses, and palisade walls. Still not unlocked.

1 Like

same issue for me, secondary objective completes in game but no achievement

1 Like

Same here! I can´t complete it too ATM

Same here. 2 bugged achievements (including this one and Protector of the Realm) before completing the full collection.

Hope dev can consider implementing the patch when closing the jungle 2021 event

No Quarter works if you don’t try to cheese it. never visit the lizard order, and slay both people properly on the field of battle

1 Like

Didn’t work… I killed both leaders but didn’t get the achievement

I opened the game today and both “Malevolent Marauder” and “Protector of the Realm” achievements popped up. Even though the game version is still the same, something must have been fixed in the backend.

I have just obtain Rhapsody of the Bohemians (skirmish, easy, just to get this achievement) and with that the Malevolent Marauder triggered too :slight_smile: