Keyboard Doesn't Work

I haven’t seen this problem anywhere else, so I’m not hopeful for a solution. Still, worth a shot.

Once I start a match, AoE4 doesn’t register any keyboard inputs. Hotkeys don’t work. Even ESC to open the menu doesn’t work, so I have to Alt-F4 to quit now. I’ve already lost ranked points for this.

When starting up AoE4 I am able to skip the opening video. However, nothing works once I’m in a match.

Things I’ve tried:

  • Disconnecting and reconnecting the keyboard
  • Verifying game files on Steam
  • Updating Windows
  • Uninstalling and re-installing AoE4

Does ANYBODY have any ideas? I’m running Windows 11, if that helps

EDIT: Since writing this post, I’ve been having similar problems in other games/applications. I guess it isn’t an AoE bug, but just in case anyone has an idea/suggestion, I’m gonna leave this here.

UPDATE: Well, this is one of the most embarrassing things I’ve ever written. It turns out I had an XBox 360 controller plugged into my computer, and the R Trigger was stuck in the pressed position.

Sooo… let’s just call this solved and move on.