Lag spikes every 5 seconds

After the recent major update I am experiencing constant FPS drops ever 5-10 seconds and it is driving me nuts. I first experienced it directly after updating when i tried the new teuton challenge. Tried it also on a standart game with AI- same result.

I checked if my driver is out of date but that is not the case. Seeing as how i havent made any software or hardware changes prior to the update im left wondering what is tha cause of these lag spkies every 5 seconds and if anyone has a fix or is experiencing a simmilar problem.


I’m experiencing the same problem, both in single player and multiplayer.

Same here and is driving me crazy! I did experience some lag every now and then, but after this update, the game has been rendered unplayable.

1 Like

I came to this forum to report this.

" Same here and is driving me crazy! I did experience some lag every now and then, but after this update, the game has been rendered unplayable ."

These could’ve been exactly what I would’ve said if LPlaceres wasn’t here first.
What is going on with this game? How can the performance change so drastically?

Same thing! Except that I already experienced it once before the patch, but with enhanced logging on. I asked my opponents when having the issue in MP, they seem not to have this issue.


same here, game freezing

Am I the only one thinking this is kinda funny? We were able to play this game 20 years ago. I myself played 10 years ago on a “not that great” PC. Game still works the same, only difference: more/better graphics. But today our PCs are struggeling with this game. Haven’t PCs improved the last 20 years? So why the **** are there so many lag spikes?? Game can be, and in almost all cases will, run on a way more performant machine nowadays, and I would rather have worse graphics and no lag than this

1 Like

:arrow_forward: GAME INFORMATION

  • Build: 4#####
  • Platform: Steam
  • Operating System: Windows 10
  • Gamertag:

:arrow_forward: ISSUE

I have massive FPS drops after the new patch. Before my machine produced 170 FPS on average (v-synch disabled). Now it trys to stay at 60 FPS even thought v-synch is unchecked. But it cannot hold the 60 constantly and has some variance which causes massive scrolling/clicking delay/lag. This makes the game almost impossible to play for me.

:arrow_forward: REPRODUCTION STEPS

Here’s how to reproduce the issue:

  1. start any single player game
  2. disable v-synch in the graphic options
  3. press F11 till you see the FPS
  4. scroll through the map
  5. see that the FPS are close to 60 (even though v-synch is deactivated)

:arrow_forward: GAME FILES

:question: Include a OneDrive or Google Drive link to a SAVE GAME or REPLAY FILE of the game where you encountered the issue.

:arrow_forward: IMAGE & ATTACHMENTS

:question: Attach a SCREENSHOT, VIDEO, DXDIAG .TXT FILE, or CRASH/GAME LOGS (if relevant).

1 Like

Hello everyone! Interesting variety of issues here! If you haven’t already, make sure you work through the basic troubleshooting steps to ensure that your graphics drivers or other software isn’t disrupting your ability to play:

If those don’t work, we’ll need an idea of your graphics settings and any other information you can provide about the problem. A video, a copy of your dxdiag, the server where you’re playing, repro steps when it happens… anything that will help our Test team dig in to a potential issue!

If all else fails, feel free to contact support, as they’ll have technical agents who can work with you one-on-one to figure out what’s happening!

Good luck! Hopefully we can help figure this out!

I have same problem. I was getting 110 fps with high settings.After last update I’m getting 90 fps with huge fps drops. Dropping to 10 fps. It’s annoying. Also I had game crash 2 times.

I partially solved the problem by resseting my Windows. I don’t know if it is a proper fix or if it just worked for me. If you have any questions, feel free to contact me.

1 Like

rather than lag spike, im experiencing chat room/lobby chat delay and its random.

i’d type a message either in lobby/chat or in game chat and it would delay up to 1 minute before it shows up. or sometimes only 10 sec or none at all.

1 Like

Made a thread about this recently, the conclusion seems to be that if we could have the option to select lightweight assets similar to the original then things should work way better