LAN problem with original AOE 3

Recently, I have had trouble connecting two laptops on the same Wi-Fi hotspot to play a local game of the original Age of Empires 3. I have been able for some time to use it with no problem in the past, after fixing some other issues. When one laptop hosts a game, the other one cannot see the game, or when the order of the laptops is switched, the laptop trying to join can see that the game exists, but I get no response at all when I click the join button. I believe that the only change since it used to work was that we changed our Wi-Fi hotspot. At the same time as the problem started, I have also had similar problems with the original Age of Empires 2 and the original Company of Heroes game.

I have updated the games, they are running on the same compatibility mode, and Windows Firewall is off when I try to play. I have also tried using my phones personal hotspot , which did not work. Any suggestions would be appreciated.

Hi there, when me and my brother where playing on the LAN game lobby one of the computers had to plugged into the internet modem for us to see and join the game. If plunging one of the computer’s into the modem with an Ethernet cable doesn’t work plug both the computers into the modem and it should work.
And the game doesn’t say CRC mismatch does it?

Hi, thanks for the tip, I’ll go try that out. No, we already had to fix the crc mismatch problem. Also, do you know what kind of cord you had was, I believe I have a patch cable. It doesn’t seem to connect the laptop to the Wi-Fi.

1 Like

I think we were just using standard Ethernet cables we used several different ones and they all worked. I don’t know if they were a specific type of cable though I’m not knowledgeable in that area. To tell the truth I thought they were all the same.
Hope it works for you let me know.

Yes One of the laptops did accept it and I was able to get the game to work. It is a little bit slow but I think I just need a better cord. I’ll have to go try it with Company of Heroes. Thank you for all the help.

1 Like

Your very welcome, glad I could help. Hopefully it works for COH as well. Happy gaming man.

It did also fix the problem with Company of Heroes

Sweet. That’s great !

Who would have thought, that cables are indeed important lol