Lost access to my published mod

I am the author of mod “Civilization Alliance”. I have received plenty of messages asking me to update my mod, but I found that I’ve lost access to all my pubilshed mod.

I also published some graphic mods with my another account, and this issue also exist while I switched to that account. I don’t think it is an individual issue.
Now what I can do is to use another account to publish a temporary new mod, but that is not what I want.

Hope this issue could be solved as soon as possible.

1 Like

I have noticed that some players have this problem. As far as I know, your already published mods should be in the same account registered in the game. If even so, you are having issues, try to delete the mod-status.json and log in again with your account.

you can also try to update your mod using the AOE mods website:

1 Like

I tried to delete the mod-status.json twice, but it didn’t help. I also tried to update it on website, but this website prevent my account from logging in. It keep turning me back to
Age of Empires Franchise - Official Web Site”. However, I can log in with a new account.

Delete the cookies for ageofempires.com and try to log in again.

Worst case scenario, you’ll have to upload the mods via the Upload Mod page, as SadBear said.

It’s what I do, BTW

it doesn’t help. I even tried on several computers, all failed.


me too.

only new mods.
havn’t old mods.

web havn’t new mods.
only old mods.

I think a change was made in the game client in the last update that may have changed it so that publishing mods now uses your Steam account (when using the Steam version of the game) instead of your Microsoft/Xbox account.

If that’s the case and you still need to update your existing ones, you should be able to log on to the web site with your XBL account and update it there.

1 Like

I also wanted to update on website, but I can’t log in. It continues turning me back to the page before I log in like this picture
I tried on several computers, all failed. This issue exists for at least one year.

Interestingly, I can log in with a new account. So I don’t know why.

What account are you trying to log in with?

My microsoft xbox account, the one I use to publish my mod. I can log in with another xbox account. That is weird.

That shouldn’t even be the case though, forcing people to juggle between accounts out of nowhere. If I need to update a mod, I shouldn’t have to find out the right account to do so, and log back into another if I want to get back my settings.

This should be fixed. Also, in my experience, using the website to upload/upate mods via the “zip” file is causing tons of trouble. I simply cannot figure out why you guys thought it would be a good idea to do this move honestly.

A bug has been filed and the game team will look into a fix. More info to come…