Map Seed different for people

I checked my replays and tried to recreate a map I played on. It generated a different map. I rechecked the behavior with some people from the AOE4 discord. I assume it is a bug, do you have any explaination on it? Is it the game? I also tried it multople times and the same map keeps getting generated which is different from what my friend is getting

Hey,
First, a few questions.

  1. I assume you have a replay, and you double-checked the map seed to make sure you didn’t make any mistakes with the seed
  2. Is the seed from the same patch? I think it has to be, or else u can’t access the replay as well.
  3. Are you sure you have no mods installed that autoplay, or has the map been generated with a mod active that you don’t have active when you try to recreate the game?
  4. Depending on the mods, they could also have gotten an update that changed map generation.

Yes I have the replay. The one with the small map was today the other one 1-2 days ago. I tried everything. Write it down. Copy paste. I also pasted in discord. this is where another user was able to get the Original Map from my replay. Mine is different when hosting a lobby. Even recorded it and shared it. No one could find any error in setting it up. Mods are deleted except the auto queue villager one. That is deactivated. Also verified the game via Steam. Not sure which mods the friends/discord users use. What map do you get?

I am just worried that my random number generator got hacked or sth. But not sure how the map generation works

Na don’t worry that can not be hacked. The way a seed works is that every number, etc., stands for some parameter. Like where is the water, how much water, the amount of wood and gold, the placement, etc. If you don’t generate the same map, that means your game does generate it differently when you remake it. The question is why.
Sadly, I’m not an expert on it. If you have good internet, you can try to reinstall the game and download it again. That would rule out that there’s nothing wrong with your files in any way. It’s highly unlikely that that changes anything, but it’s worth a try if you have fast internet.

I reinstalled but it did not solve the issue. I also noticed that it shows a custom map in my map selection screen but i deleted all mods. I assume it is somehow stored in my steam cloud? Any way to reset it without loosing my levels/achievements

Hm nothing I can do to fix this? A friend said maybe a hardware topic? The custom map is pre installed by the game btw so I have a vanilla setup