Massive FPS drops when selecting units

o i have a rtx 3090 with a I9 10850K Cpu. 32 gb Ram. Running the game at 4k.

It’s fine most of the time. FPS sits around 102. But holy ■■■■ whenever i select units it just drops massively. Selecting 40+ units drops my FPS with around 80. Selecting 50+ units is already near impossible to play.

It even drops 10-20 fps when selecting villagers. I don’t know what this is all about but i believe my specs are enough to run this game.


do u have a multimonitor setup?

Thanks for the report. We’re going to have our team look into this to see if they can replicate the issue.

Ok i figured out the problem i think. Whenever i set the setting ‘‘Geometry Detail’’ on Ultra or Maximum i get these fps drops. Turning it back to High seems to have fixed it. Looks like there is something wrong with cranking this option up.

EDIT: nvm. Thought that fixed it. But it didn’t. Just played a match where i had the same issue again.

1 Like

I can confirm, have the same issue, when selecting any unit, higher fps drop whit more units selected. I do use 3 monitors, but only playing games on one @ 3440x1440

Hardware used: Ryzen 9 5950 @ 4,7 GHz OC (Custom Water Loop), 64 GB @ 3600 MHz CL 16, RTX 3090.

I have a Rtx 2080 Ti with a Intel i7-10700KF CPU @ 3.80GHz and 32 Gb Ram

and Same problem here!!!

Selecting 50+ units is already near impossible to play.

Hi. I also can confirm the issue.
My settings are with preset “high”. I play with 2560x1440 resolution with one monitor.
My PC configuration is: I9 9900k, Asus 2080 TI, 64 GB Ram and it runs on a Samsung SSD 1TB

when selecting over 60-70+ Units my fps drops until 30 sometimes 10-30 fps.
Then I get a message from the game that I should change my settings :smiley:
But after doing so, nothing changed. When I remove the selection the fps will get higher again.
So I guess the issue is about how the selection is beeing processed or something like this. And not the graphic at all

Same issue here! Im unsure if this always happens as I had a few campaign missions with like 80 units before and everything was fine, but currently its unbearable.
Every graphics setting is set to max at a 1440p resolution.

I posted a vid on reddit, just watch the fps counter at the top right. Its a drop of around 50fps just by selecting a large group of units:

CPU: Core i7 8700K
GFX: Asus TUF RTX 3080 OC
RAM: 16GB Corsair Vengeance 3000MHz
SSD: Samsung 970 Evo

It looks like it happens more often in campaign missions. Can confirm this. However i had this on multiplayer a few times aswell. Just not as often.

1 Like

i have the same problem… they have to fix it… its really bad think that u have a good computer and cannot run the game properly…
i have more than the especifics setup to play in ultra high
but i cannot play more than medium and everything low

For me, seting the graphics to low doesn’t change anything.
And I didn’t recognized the issue in any campaign it was more often in normal skirmish gameplays no matter if alone or in MP

AMD Ryzen 5 3600X 6-Core Processor 3.79 GHz
32.0 GB Ram

Run the game on all settings (low - highest) and get the same issue. Becomes unbearable to play late game when there is a larger unit count. Its improved my rush game. However when playing with friends who are using worse CPU’s/GPU’s who don’t seem to have as bad of an issue with this. I’m freezing entirely.

My machine is liquid cooled - GPU is barely working that much but something is going on.

Windows 10 - fully updated
GPU - Nvidia Latest drivers

Game is obviously updated too. Happy to provide system specs if required.

AOE is likely the best game but with the fps i’m struggling to enjoy it fully.

Okay thats interesting… Today I noticed that these drops occur randomly. Yesterday I started the final france mission and had horrible fps slowdowns(from ~130fps down to like 30-40) when selecting the big army after carentan fell. Today I restarted the mission and have little performance slowdowns(around 10fps loss).

So maybe its tied to how long the game is running? Maybe the code that shows/hides and spawns the rings around units doesn’t clear them over the course of the game?

Did anyone ever find a fix for this? I have tried a ton of different settings (in game and out of game windows, nvidia etc). I opened a support ticket and included the necessary info but the suggestions they gave me were all things I tried with no success. This problem is really ruining the game for me. Hoping someone out there knows something.

AOEIV is so full of bugs I wouldn’t even consider it “Beta” (and I’m a software engineer). After upgrading to Windows 11 (AMD 5950X, Titan RTX, 64GB RAM, M.2 NVME) the game starts out with great FPS 113 or so … after about 20-30 minutes I’m at 7 FPS and the game goes out of sync and becomes unplayable.

Researching this and I see MANY other users with the exact same problem. Unfortunately I get ZERO feedback from the developers or support. They just toss out the “generic” have you updated your BIOS, your drivers, etc. etc. … yes I’ve done all that, I’m a freakin’ software engineer and know my PCs.

This game is worthless to play under Windows 11. BTW, worked fine under Windows 10 so it’s clearly a Windows 11 and AOEIV issue … other games like Anno 1800 work just fine as do my other games, this issue is specific to AOEIV and ONLY AOEIV.

I have a very similar high end setup 6900xt 5950x etc, and sometimes I get 5-7 fps even at the start of the game. It goes away sometimes. Sometimes I need to restart it. What I have found is that disabling anti aliasing gives a massive fps boost. So if you have a high pixel density 4k screen you can try that.

it happened to me in the pup, but removing the shadows it seems to be fixed

It would be nice if the AOE dev team at least acknowledged they were looking into the FPS problem under Windows 11.


I solved the FPS issue under Windows 11 by doing the following:

  1. Disable G-sync via nVidia Control Panel
  2. Set refresh to 60Hz
  3. Win11 Graphics settings - Hardware-Accelerated GPU Scheduling = Off
  4. Win11 Graphic settings - set AOE IV to “High Performance”
  5. VRR option should not be present if step 1 is done correctly, if it is disable it (Off)
  6. In AOE IV graphics settings:
    a. Vertical Sync = On
    b. Framerate Limit = 60 FPS
    c. Game Window = Exclusive Fullscreen

Set your other graphics settings however you like. The key seems to be G-Sync disable and setting Framerate Limit = 60 FPS (or 30 if you prefer).

I tested with two 1+ hour games 4 AI, 2 Multiplayer, everyone maxed out 200 pop cap, not a single FPS issue.


It’s being worked on :slightly_smiling_face:!

Also, thank you for your solution. Hopefully this helps those with this issue while we work on the problem on our end.