Megathread: Bugs caused by modding or in editor

Hey, all!

This pinned thread is here to collect bugs that are caused in-game by mods. Officially we don’t support player mods in that fashion. It is up to the creator/modder to properly support any mods that s/he releases. That is, of course, unless it’s an official mod then it’s on us.

HOWEVER, we realize that it isn’t quite as simple as that, and would like to know the types of issues modders/players are experiencing so we can look into how to improve our tools.

The exception to this is any bug that causes crashing, freezes, desyncs, etc. Please continue to post those as separate bugs.

Thanks!

2 Likes

This is primarily problem for modding, but also for regicide or any other game conditions that needs to know when unit was killed.

This issue is for both land and naval transport units. But is problematic only for naval one as these are killing all units that were onboard, when they are killed. e.g. Killing transport ship with 1 villager will fire only single event that transport ship was killed. Villager is just despawned and there is no way to retrieve that information. Game does not fire events that are shown in scar documentation for modding tools.

All units held by the transport ship should fire some kind of event that they are being killed. Ideally the event should also provide the information who killed their carrier.

Note: this should also consider a situation when Transport ship is carrying land transport such as Ram or Siege tower. As in that case there is chance that land transport is carrying units. So the event should also fire for these units.

1 Like

This is related to mods, Ottoman Galleass are not categorized as transport after receiving the miiltary school upgrade, which allows them to carry troops

1 Like

After moving stone towers, wall and gate via Tuning Pack to Age3 menu for Delhi Sultanate. Clicking on Infantry units and then on Villager will cause Villager build menu to have age2 buildings located in age3 menu and age 3 buildings located in age 2 menu.

This bug happens only for Delhi Sultanate, all other civ with exact same change work fine. (Including ottomans that are inheriting menu layout from Delhi)

selecting villager


selecting villager after previously selecting infantry unit (spear, archer, crossbow, maa, handcannon)

and yes, it’s purely visual bug

It remains like that until non villager unit is selected. Going from something like building to villager will display it correctly

2 Likes

First of all, the “Lock AI Difficulty” checkbox for AI players does nothing. The difficulty can still be set by the player in the skirmish lobby regardless, and the dropdown menu for it isn’t greyed out like the other options (race, team).

Secondly, even if the checkbox did work as intended, restarting the mission from the pause menu will just revert the AI player’s difficulty back to whatever difficulty the modder set it to! That means that even if you want the player to be able to choose the AI player’s difficulty in the skirmish lobby, it’s likely to change if they hit restart. There doesn’t seem to be a “let the player choose” option for the modder to select. The modder’s options here are Easy, Normal, Hard, Expert, Cheat1, Cheat2, Cheat3 and Default (which seems to just mean Normal).

4 Likes

Dear developers,

I wanted to express my sincere gratitude for creating this post. As an experienced gaming modder with a passion for crafting large maps in Age of Empires 2 and 3, I have already built several maps, but I must say that the editor can be quite challenging to work with. Thank you for addressing these issues and striving to provide the community with a powerful tool that it can truly be.

Overall, the editor is good, but there are a few missing options and usability improvements, especially for modding beginners. Despite having a high-end system, I encountered three total crashes, spent over 10 hours debugging files, and invested more than 30 hours in just one map. The map I created is a high-resolution, maximum-sized map for 8 players, featuring two large water zones that separate the two sides and include tactical transitions. However, the biggest problem I faced was the lag. Whenever I tried to select an object, it felt like I had enough time to go grab a coffee due to the thousands of white 3D render lines that I couldn’t successfully disable. This made it nearly impossible to stack objects precisely. For instance, when I wanted to copy a forest and paste it slightly lower in a valley, pressing the paste button resulted in a mess of white lines, obscuring the actual objects. It became extremely challenging to align everything accurately with the terrain.

It would be incredibly helpful to have a feature that outlines the objects on the ground, as the “snap to ground” functionality doesn’t work well. This way, we could clearly see and position the objects. Additionally, for Lua scripting, it would be great to have an easier entry point, such as pre-made snippets that users can customize. This would encourage more people to utilize this fantastic feature, as it offers brilliant possibilities.

Another issue I encountered is that file updates between different components don’t always sync correctly. Texts like short descriptions don’t get updated anymore. If, at the beginning of a mod, I didn’t choose the perfect title or description text or made a simple typo, I couldn’t change it. However, the long description works fine. It would be helpful to have a text file in the mod’s folder that users can easily edit for these purposes. This brings me to the topic of minimaps. At a certain point in the map’s development, it became impossible to generate a playable minimap. When I updated the mod, everything looked great, but in the game, the minimap appeared in various shades of purple, and the upper right third was completely pink and non-transparent, rendering the entire map unplayable. Moreover, the program would crash whenever I opened the mod. The only solution was to rewrite all the files in a new mod. This happened to me twice, and I can’t imagine how many people might have given up in such situations.

Another aspect to consider is the thumbnail preview. Providing users with a small tool that allows them to drag and drop an image onto the map, add text, and press a button to create a beautiful preview image would be fantastic. Yes, using mod.png is also a solution, but it’s not intuitive for many users. Additionally, I encountered an issue where the map was saveable, but the entire project couldn’t be compiled using the “Build” button, as it was grayed out. Furthermore, I experienced a graphics bug that displayed the entire map in the colors that were used for the minimap, making everything indistinguishable. I had to adopt a backup strategy to constantly rewrite the files. It almost felt like hacking rather than modding.
I want to address a peculiar bug that I have encountered while working on my maps. In hidden forests, dead trees and some douglas firs are inexplicably displayed as red boxes in the game. This issue is extremely frustrating, as it requires individually testing each tree and scouring the entire map to locate and remove these erroneous objects. I spent a good two hours on this task alone, and even though I tried hiding them using the visibility option in the item list, the red boxes persisted. It was quite a time-consuming ordeal.

This is just one aspect of the numerous challenges I have faced. I believe it would greatly benefit the modding community to have an official introductory video showcasing the possibilities and potential of the modding tools. While the existing documentation is well-structured, it often falls short in providing comprehensive content, leaving users in the dark. Having a series of five videos that introduce different mechanics, such as the tooling for creating the basic layout or combining traditional drag-and-drop methods with the ability to add code to objects without having to learn programming for years, would be immensely valuable.

Furthermore, it would be a dream come true to have a terrain tool feature where I could select an area and have the objects automatically adjust to the underlying terrain when smoothing. Currently, it is a laborious process to manually readjust everything. Another feature I couldn’t find is a hybrid solution that allows me to click and generate the basic map using the terrain editor and then display the complete generated code in a separate window. It would be incredibly helpful to make certain adjustments directly in the code, while still benefiting from the convenience of the terrain tool. It would be great to have a button in the context menu of each object that allows me to jump directly to the corresponding code section.

Implementing these enhancements would make modding and map crafting much more accessible to a wider audience. Currently, it requires a significant amount of pain and understanding of the underlying structure, making the learning curve too steep, even for beginners. I eagerly look forward to engaging in further discussions and exchanging ideas.

Best regards,
JamanKarl

the map is finished it is called “DeepMind” and has already had over 600 views in 3 days, which makes me very proud and makes the pain worthwhile
here short photo documentation, have more but can post only one.

the purpel look bug

1 Like

I have discovered a bug that when I use mods and I want to play the Mongolians, they just don´t spawn. So the villagecenter and the start villagers just dont spawn. Is that a problem some of you maybe experienced? How can I fix that when using mods?

2 Likes

There is also a problem with the old nations like England or France (all except Malians and Ottomans) that when using population mods they doesn´t get any start villagers. Is that wanted?

1 Like

Since the update to season 5. Noticed acouple problems with the editor. Mainly crafted maps

When you use the layout tool and generate a map it works good the first time. If you make some changes with the laytool again. Seems to over lap the old trees and just leaves a missing area. It looks like the stealth ground.

Before you could add the enchanted stag to a crafted map. If you try to now it crashes the editor

Browsing the mods section in game gets stuck loading sometimes.

Thanks, all! We do continue to look at this thread, so please continue to post here. Much appreciated!

1 Like

For me I cannot get no population increase by any mod. Only solution I get is use advance game mode, but if I do AI creates non stop mill and lags the game, and also all unit some time gets stuck on same position.

1 Like

The editors been crashing very often lately. I just press on something and the editor just disappeares, then have to restart it and lose what ive done.

Not sure if its the new update. Formated my computer and installed win 11 couple days ago. Since then feels like the editor and steam are conflictioning with each other

1 Like

Minimap bug

Use to have this problem and seems to have come back again. Every thing was ok the last few games, then this happens. Ive tried everything I know but nothing works.

minimaperror

Creating Palettes

From the official site
Palettes are created in the Palette window and once saved, you can find them in the Object Browser.

These Palettes are saved locally and will show up in the Object Browser regardless of what map you have open.

They only show up in the map you have created, not in any new crafted maps

Plenty of bugs on mods!
Suscribe failed appears everytime


Can not play!

The Essence Editor has a serious bug where it is not possible to add SQUAD_FORMATION_EXT to SBPS, because when trying to run the mod, it closes automatically in any game mode. Additionally, in any SBPS with more than one EBPS, only one unit accepts commands while the others remain stationary near the spawn location.
This problem makes the SQUAD_LOADOUT_EXT function where we put the number of units in each squad useless and greatly reduces the possibility of creating fun mods like COH.