[Merged] Overlay Freezes

I have the same issue

  • Build: newest
  • Platform: Steam
  • Operating System: Windows 10
  • Gamertag: mitmit

Programming with old code is tricky, don’t mind if there are issues, just reporting to be fixed.

not if you are good at your job

Many players are having the same issues thanks to the devs

i got maybe 3 times but different way of this bug.my game closed between 20-30 min by itself and i lost elo.

Same issue?

2 Likes

Yes same issue I posted it on his thread.

No. The overlay was completely fine, even the feedback for unit orders etc. was given by the game and I could move my view of the screen -Only the game itself did not react ( no unit actually moved when clicked, no resources were gathered etc.) - The game did not crash at all but was rather stuck in a state of limbo until I left the party. I was, without restarting the game, able to play other multiplayer games afterwards.

Game Version:

  • Build: 101.101.37650
  • Platform: Steam
  • Operating System: Windows 10
  • Gamertag: asmo

Issue:

Playing online matches almost everytime the game get frozen, like lag, but it do not come back. I can move over the map, i can select unit and they make noise but they dont move or do anything. Any message appears, not disconnect or anything. I tried to wait a long time and it doesnt do anything. Finally i have to quit the match, exit the game and finish the process because it keep going even i closed the game.
It doesnt happen always at same time, it is random. Internet conection doesnt fail because it still working. When internet stops working disconnect message appears.

This is the last game it happens to me

MP Replay v101.101.37650.0 @2020.05.31 122036 (4)

Game Version:

  • Build 37650
  • Platform Steam

Issue:

Match froze in the middle of the game. I could still pan around the map, click units and buildings but I could no longer give orders. All units (mine and opponent’s) were frozen, buildings as well. I waited for a few minutes, tried to pause/unpause the game (I could see the message “you have x pauses left”) but nothing happened. Eventually I quit the match and went to the statistics screen where I saw that I lost ELO points.

I checked the recording afterwards and it just ends the moment all units froze (the recording doesn’t contain me waiting around for the game to recover).

Reproduction Steps:

  1. Just play the game

I have not taken a screenshot, but I can upload recording if needed.

Hi

Has anyone else had this problem? I start a game but nothing can move.
I can select any unit and give it commands but nothing works.
I tried chatting but no one seems to respond so I just quit the game.
Can anyone message me when the game works again?
Guess I’ll quit for a couple of days/weeks then.

1 Like

Game Version:

  • Build: 101.101.37650.0 0
  • Platform: Microsoft Store
  • Operating System: Windows 10
  • Gamertag: EL ROYMOND

Issue:

After the latest May patch, the game keeps freezing. As in disconnecting or something, and the game is lost. I’ve lost about 100 ELO ranking points now to games like this cos it’s happening in almost all my games. It’s basically unplayable at this point. It’s weird cos it’s like it’s a disconnect but doesn’t give you the ‘you have disconnected… save restore has been made’ notification. Nothing. Just frozen screen (you can move round map and chat, but no reply of course).

Reproduction Steps:

Here’s how to reproduce the problem: Just playing any game, at some point it will likely come up frozen (as if severe lag or someone disconnected or paused) and then never change. The game’s gone. It’s likely a disconnect but then nothing is notified and other person doesn’t chat back.

Attachment here shows what it’s like. You can move round map (w/fog of war), and chat, but it must be disconnected cos no reply from any opponent. It’s very frustrating as it didn’t happen before the latest patch, and it’s in most games, making it unplayable right now.

6 Likes

I have the same issue…

A vpn connection minimizes it, but not totally

I’m using a VPN. When I don’t use the VPN it disconnects frequently, but you get the notice and it tells you it’s disconnected.

This one is new for me, it’s frozen in place and it looks like it’s disconnected but without the notice.

I’ve been using a VPN since playing online again under lockdown, and this one is new since the patch on mine. Such a weird bug.

Same here, it happens in most games, general freeze. Only solution is to quit the game and relaunch another one…

Same. Temporary workaround is to save, quit and recover. But this is a disaster. My friends thought I was still playing and I thought they were lagging too. We need a hotfix @GMEvangelos

can u check if server was Brazil ?
https://aoe2.net/#aoe2de-matches-my-recent-matches

Just had this exact issue happen in a game for the second time and the server was Brazil both times, they were also 3 v 3 games.

Game runs perfectly with no lag and then about 25 minutes in this happens.

2 Likes

How can you check server on the Microsoft Store version? I don’t have Steam account.

These are both 1v1 and 2v2 games btw. I haven’t played MP 3v3+ yet. I’m based in PH but have to use a VPN for other issues. VPN is in Hong Kong. It’s happening in more than half of my online games. Just happened again :frowning:

here it happens for HOANG, 1v1 , just right now
7:56:20