Message "You do not own the return of rome DLC" despite owning it

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: 101.102.18071.0 (#83607) 0
  • GAME PLATFORM: Microsoft Store
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED

:point_down: I bought the Return to Rome DLC, installed it on the Xbox app, and when I try to access the content by clicking on the “Return to Rome” icon in the left navigation bar, I get a message that reads “You do not own the return of rome DLC. Click the Go To Store button to purchase it”. I double checked that the DLC appears installed on the Xbox app, and also when I click the Go To Store button, I get a message saying “Already owned. Looks like you already own this”. I also tried restarting the game several times and nothing works.

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

  1. Open the game.
  2. On the main menu window, click on the “Return of Rome” icon on the left navigation bar.

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?

The game should redirect me to the Return of Rome menu.

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.

:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe2spgame) or GAME RECORDING (.aoe2record) of the match where you encountered the issue. Link it below if using an external file service.

  • this wasn’t in a match, it was on the main menu.

I am having the same issue been trying to get it working since it came out, tried everything I could think of to fix it and also everything they sent me to try and still not working

Same too me but in Steam version

I have a similar bug. I managed to get RoR to run on the first instance, but it crashed during Trajan 2. Now every time I try to re-enter Return of Rome upon restarting AOEII DE, the game crashes on the loading screen when switching between both clients.

I reported this issue to the team, it might be possible that the server is laggy sometimes. Do you still encounter this issue?

Hi @Felizon89 what I tried yesterday night, I downloaded AOE2 on my Xbox Series X and played a game there and it worked. After that, today I found that it’s working on my PC as well, just played a bit a few moments ago. Don’t know if playing it on the Series X did something or it’s something you did during the night (I was contacted by AOE support at midnight, they were asking me if I owned the game, I told them I played through Game Pass and only bought the DLC), but now I can play. Thanks for the help!

Still same error! I just remove the DLC download again and same issue! What I can do more? I feel I was riped off!

I reported this issue has high priority to the team, but this might be a problem with the server, I hope this issue can be fixed soon. Sorry about the inconvenience :frowning:

I just got the extension and got the same problem. Installed on PC through the Xbox application. When I clicked on the go to the store button and connect to my account, it confirmed I already got the extension but it still did not work.
I opened the Microsoft Store application (not the Xbox one) manually outside of the game and found all the extensions installed. After that, launching the game one more time before reporting, it worked…
I don’t know if that’s going to defenitely solve the problem through.

Hi there;

I bought this DLC today and experienced same issue. For me it was because my Microsoft account on computer was different to the pc gamepass email.
I signed into Microsoft store using same email as registered on game pass and it worked straight away. (I also ran a quick update of pc to make sure)

I tried playing the DLC on my Xbox, then went back to PC and it worked. If you have an Xbox maybe that’ll work for you too?

Continue with same issue! Reinstalled the game and same thing. I don’t know what to do any more.

I don’t have an Xbox :disappointed:

Thanks I will give a try and I will let you know :+1:

Something i did that got it to work is click on my account in game and clicked on view profile, little guy at top of screen. Not sure if that refreshes a cache of some kind or something but after doing this it appeared the tab on the left let me into the game.