Mexico unlock challenge broken?

so I’ve been sat here for 2 whole hours grinding XP for the first challenge to unlock Mexico, and i have nearly 100,000 XP and am still level 4, when i need to get to level 5 to beat the challenge. Does anybody have any idea whats going on?

1 Like

UPDATE : just reached 100,000 XP, still level 4

1 Like

there are no challenges to unlock the faction.

did you ever solve this? thanks

1 Like

Have you tried re-launching the game and trying again?
The first challenge should allow you to “check” the level of your Home City - if not, then you will be able to play match by selecting “begin” and in that case, the challenge should unlock by completing the match (you can just resign in a skirmish).
If that still is not working, you can try gaining a level in a Skirmish. Using the cheat “Nova & Orion” will grant some XP, as well as building most military or having best economy.

My next suggestion would be to enable Cloud Saving, make a copy of you Aztec Home City .xml file from
C:\Users<user>\Games\Age of Empires 3 DE<0000000000>\Savegame
then delete the original and launch the game again to generate a new file. If this does not work, then you can replace the “new” .xml with the copy from earlier.

Hope this helps!

1 Like

Have you tried resigning or winning that game and starting a new one? You can’t gain more than 3 home city levels per match.

This challenge worked for me on the first try.

1 Like

I had no problem for this challenge

I also didn’t had any issue with it, but i had the levels from before

I’ll give it a go thanks.
i’ve tried playing direct from the challenge and in a standard skirmish game, aztec home city stays on level 1 and won’t go above 4 during the game, pretty frustrating.

Read my post above. Also, cheat codes are usually not permitted to complete the challenge.

i’ve won multiple ones