MIcrosft Store Installation corrupts hole System!


I bougth a key for “Age of Empires II: Definitive Edition” in Microsoft Store form some Website ( i know, but my budget is low, so…). The key worked fine, so I startet the Download/Installation.
Before the Installation finishes, there is a system crash, wich apparently corrupts the operating system.
After that, Windows is no longer able to sart up! So I completely reinstalled Windows 10. Whitout installing any other software, I tried to install AoE2 again, same thing. After the Crash, Windows would not start up. So I am quite sure, it has to do with this Intallation form the Store, like its some kind of broken Update !!

Has anyone exprieneced the same problem? Im quite shocked that a game intallation destroyes the hole System !!! :frowning:

Is ther another source for Installing the Game ( besides the Store, I´m not trying that again) ?
Or is there a way to “retun” the Key in Microsoft Store ?

I am quite annoyed to be honest, after re-installing the hole OS two times in a row !!

Thanks for your help!

Greedings form Austria,


(who is sorry for not buying the game on Steam :smile: )