Microsoft Store Package Dependency Installer

Hi can anyone i keep getting asked everytime i try to play to allow Microsoft Store Package Dependency Installer clciking no doesnt launch the game and clicking yes does but then crashes half way through a game…i didnt have a issue until i had o do a re-install of my windows


1 Like

Hi @hades8840, Are you having this issue with Age of Empires II: Definitive Edition or Age of Empires: Definitive Edition?

Hi with Age of Empires II: Definitive Edition

hey! did you fix this issue? The same thing is happening to me on Age of Empires II: Definitive Edition

No and now its got worse game is closing down while playing no reason to why its running fine then all of a sudden it will just go back to windows screen no errors no freezes nothing to say why

i’m having the same issue it doesn’t even make it to the loading screan i get an error going to try reinstalling will let you know how i go

Same thing for me?

Tried everything, can’t launch the game anymore…

Same issue here. Any ideas?

Hi had the same issues with PC Version, after a reconnection with my Microsoft X Box Account the game starts and works!

Game runs again, but I don’t know exactly why.
I uninstalled and reinstalled it several times; after logging in with a local user on my pc and logging in with my microsoft-account in the microsoft-store and installing the game again, it worked.

Hi. Same issue, ever since the last update, Microsoft Store Package Dependency Installer will not allow me to even launch the game. Please help!!!

Try to run it below (another) local administrator account.
Is your user account administrator or normal user?
Also check for all other updates in MS store application by using the download section there.

Thanks for the reply. My account is admin. Checked for all other updates and none show.

Right click op the app tile and choose more and app settings.

There you can find a button to repair the game. If that doesn’t help I would cold boot your pc and router and after that test it again. Before that you could also try by signing out from Xbox app and MS store before (cold) reboot.

Eventually had to do a re-install. Seems to be working now. What a pain that was. Appreciate your help and advice. Thanks

1 Like

I’m playing AOE DE ad it seems to be doing the same thing. I went in and I guess there is a 10 gig update now being required today. Hopefully this fixes it.