Minimap bug no markers with amd gpu

Hello, I used to play AEO 4 on gamepass with a Nvidia RTX3080. Since I upgraded my GPU to a RX7900XT, I got a bug with the minimap. I don’t see any marker on the minimap. I am playing on windows 11.

On the picture below I was playing a skirmish game just to edit my shortcut I want to play ladder. As you can see no markers whatsoever, I spotted gold vein and an opponent TC. Minimap is broken.

I had no issue whatsoever before playing on gamepass. Since I got my amd GPU. no minimap.

how can I fix that?
Thanks for help

1 Like

Same issue for me on a 6700XT. Issue only started recently.

Although in my case gold also shows no actual gold vein on the rock and unexplored areas are just as lit up as the explored. Only darkness in my game comes from the clouds rolling over the screen.
I’ve tried everything to fix it. Verifying game files, reinstalling, changing all the graphics settings, fiddling with various Radeon settings, updating drivers and rolling back to earlier drivers. Nothing makes any difference. :man_shrugging:

A fix would be great.


1 Like

OMG I am not the only one! thanks for your response man. I appreciate it. I am getting mad of it. I have the same issue with gold vein, well we got pretty the same issue, at least I am happy this is not my graphic card. I had a doubt for a second.

please guys, fix it, load of people have AMD card.

Thanks for your support

1 Like

By the way, I got an issue with the fog war, mine is not working properly I can see the entier map(landscapes) at the start of the game. the FOG is white not Black. Please help us

Hey, all! Sorry you’re seeing this. If you could please contact support with your DxDiag and warnings.log file, it would be very much appreciated. Thanks!

Haha. I thought i was the only one having this issue also. Good to see im not alone here. Hopefully we get a solution soon :crossed_fingers:

1 Like

Onto it boss! Ill get that sent through in the next few hrs.
Cheers for your response buddy :grin::+1:

1 Like

thanks buddy to sent the DxDiag have no time and no clue how to do that. my last hope is on your shoulder! thanks

I have contacted support earlier today and provided all the info. They have no clue what the issue is and have forwarded my DxDiag and warnings.log file to the Devs.

I have also looked through the warning.log file and the first of many errors that appears is -
(I) [00:29:32.590] [000016076]: Loading step: [Property Bag Manager]
(I) [00:29:32.906] [000016076]: MapGen - Failed to load: attr->AttributeExists_PL(name) || attr->TableExists_PL(name)Failed loading an attribute data field for map generation. It is likely that your attribute data is out of sync with your local build or build from the build launcher.

There seems to be many more following referring to various attributes failing to load and other stuff that I dont understand haha. So hopefully the devs will have some idea what the issue is and be able to provide some help. :crossed_fingers:

The problem you are having appears to be identical to mine in every way so if I end up getting a solution, I’ll be sure to update here for you.

good mate. team work will save us (hoping).

Gents, I have the EXACT same bug since the Enchanted Biome patch. I have tried all solutions the support provided, but everything has failed for me.

They must have changed something with the patch that completely undermines some functionality with AMD. I tried everything and have no clue how this can be resolved.

@SavageEmpire566 since this problem is surfacing with many more people Id be very grateful if the developers would take an in-depth look into this issue. Id be so grateful to simply play one normal game after months of living with this graphic error.

EDIT: I need to mention that I have also considered AMDs latest software scandal and the Windows 11 graphic overwrite issue in my troubleshooting. Both of these issues would have been the most rational explanations for the graphic bug, yet other games with demanding requirements run without any problem.

The only rationale I can come up with is that something was implemented in the last major patch which causes some sort of incompatibility.

1 Like

If you haven’t, please do this :point_up:. With any very specific issue, the more data we can get, the better.

If you have a chance to check out the PUP build (game ownership/Steam login required) going live here in the next 15 or 20 minutes, please give it a shot and update here if it’s any better.

I have loaded the PUP Build and it did solve graphic distortions such as with the gold mine (Same problem @woozy00woo displayed).

However, the minimap is still broken. No entities are displayed and there is no fog of war, just visible terrain without assets loaded. I have forwarded this problem to the AoE Support weeks ago.


Weird, I have an 6800XT and I also migrated recently from an Nvidia RTX but my minimap is fine and I have never had any visual glitches with it, AMD or Nvidia.

Out of curiosity, do you have an Intel or AMD CPU? I’m still on Windows 10. Perhaps this could also be a Win 11 - AoE4 thing?

@EricGonzalezM You have commented the same thing on my last post weeks ago. It is not weird, we are having a serious problem. YOU ARE NOT HELPING.

1 Like

WTF. Chill pal. I AM helping saying that it’s not just a GPU issue. There must be other variables at play here. Asking what systems folks are running will aid in narrowing down the problem.

If you don’t like that then I guess you’re free to block me. Jesus!

1 Like

If this problem occurs after one and a half years of flawless functionality with Win 11, then it is an issue that was implemented with said patch.

The only problem that could have occured in the latest updates of Win 11 was already troubleshooted against.

Thanks for checking! I have bumped this one with the team.


Ok, so I have tried the PUP build.
The issue with the gold vein seems to be fixed.
Sadly, the rest of the fog of war and mini map marker issues remain.
And now I have an issue were certain textures flash in n out of existence. :man_shrugging:

1 Like