Mod stuck on finalizing download

This is happening for some new mods and for updating some old mods (not happening for all mods).

Eg “Zycat AI Lite” won’t update, and “Flavius Micro 1v1 Alpha Version” game mode won’t download.

I have tried verifying game files and this issue is still present.

Build 5.0.12973.0

We are tracking a bug that sometimes causes this to happen and hope to have a fix soon.

If you attempt to download the mod at the point where it gets stuck on finalizing download, then restart, does that allow it to finish?

1 Like

I have the same problem with at least these mods:
Heavens Hill
Unit tester
Zycat AI lite.
The mods which I had not subscibed to before today but tried downloading stuck in Finalizing download show up in notifications after I restart the game first as finalizing download but then change to unsubscribed
If I look at my mod manager I have only Zycat AI as subscribed but out of date
Other ones I listed show up in the notifications but they are not in the mod manager page

Restarting does not fix the issue for me.

I’m having the same issues, and as someone who loves making maps and tuning packs, this is a major turn-off.

The “finalizing download” or “finalizing update” comes after the download/update bar hits 100%. Upon hitting 100% it says one of those two phrases and never changes.

This is happening when I try to make updates to my current mods and/or when I try to upload a brand new mod. If I host a custom game with a mod that I haven’t made any changes to today (one that was made prior to today), then I have no issues whatsoever–the game loads like normal and the other players load the mod without issue.

Old mods that weren’t updated in the past few days works fine, but not new or updated mods. I can subscribe to older mods but not newer ones.

i recently updated my mod now nobody can use it, always stuck on 0/1 in lobby
i tried making it from a scratch same issue

I appreciate the continued reports. I’ll leave this open for now in case any new info surfaces. We’re definitely aware and looking into it.

This is what it looks like when I tried to click on the finalizing download stuff sometimes. The other times it takes me to other mods which is weird.

We are experiencing the same issue. We successfully published a mod yestereday, however when we published one today (Choppy Choppy) nobody is able to download it. Stuck on “Finalizing Download” and get the 0/1 with a Green checkmark if I try to load into her game.

it appears to be fixed now
Much thanks!

1 Like

I haven’t tried uploading or updating mods but the ones that were uploaded works fine now. Thumbs up.

1 Like

This is fixed for me now too. Thanks Devs!

1 Like