Mod website not updating mod properly

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED


I’m trying to update the Rome at War Graphics mod (part 1 of 2), but it’s not actually uploading properly. It starts the loading wheel like expected, which then spins for 20-30 mins, before disappearing without actually changing anything. There’s no error provided, and the update doesn’t go through.

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

  • I’ve only been experiencing this today (although I have had a similar issue a long time ago)

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

  1. I’m not sure how to provide repro steps, as the mod is something I’d need to update

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?

Updating the mod works as intended

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.

It’s just the regular spinning loading wheel, and then it goes away with no results.

:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe2spgame) or GAME RECORDING (.aoe2record) of the match where you encountered the issue. Link it below if using an external file service.

  • N/A

@DodoNotDoDo, are you able to take a look at this? Thanks.

I checked the logs for the last week and I’m not seeing where the publish attempt is hitting the server. I see where you published the datamod a couple times, but that’s it. You might check your local version and see if recent changes introduced any files or file names that could be causing problems for the game. If you haven’t already, you could also try publishing via the web site vs from in game and see if it works there.

Update: just realized this was already when trying from the web site. Have you tried from in game? I’ll check the web server logs too.

Update 2: nothing in the web logs. I was able to republish your existing version, so in general things are working, so seems like it’s something specific to your update.

1 Like

isn’t the in game section currently broken iirc. the game doesn’t recognize in game login and won’t let us update because the token issue, unless that has been fixed but haven’t seen that in any of the past patch notes.

I managed to update it through the ingame mod manager, so that’s good.

Honestly, the website for mods never worked for me properly. Only in-game. (Except the Screenshots/Preview Images thing. I always use the website for that and nothing else…)