Modded unit attributes in data mod can't take effect, but modded techs can

:arrow_forward: GAME INFORMATION

  • Build: 101.101.37906
  • Platform: Steam
  • Operating System: Windows 7 & Windows 10
  • Gamertag: NeroXClaudius

:arrow_forward: ISSUE

An issue that units’ attributes and grathic data remain to be those from origin DAT will come out when we select and load a DATA mod whch is modified from the origin DAT of Build 37906. But meanwhile, the modded techs data can take effect normally. For excample, if we modify Archer by setting it to 100 HP, then ingame the Archer’s HP still remains 30; if we delete the hero-radiance graphic in a specific hero’s graphics list, then ingame his radiance remains.
By the way, this issue is nearly same to this topic, you should pay attention! It has “rised from the ashes”.

:arrow_forward: REPRODUCTION STEPS

Here’s how to reproduce the issue:

  1. Modify anyone unit and tech in AGE(Advanced Genie Editor).
  2. Save the change and put the modded .DAT into a local data mod folder.
  3. Import this local mod and enable it.
  4. Select this data mod and start a standard game.
  5. In game, train the modded unit, research the modded tech.
  6. And then you will f*cking find that the tech will have taken effect, but the unit’s won’t change at all - it is still the default data.

:arrow_forward: GAME FILES

:arrow_forward: IMAGE & ATTACHMENTS

maybe you didnt click the copy button on the very top after you edit?

As @thieftdp8498 said, you need to check the box for automatic copy to all civs.

1 Like

Yes, I clicked copy, but it still didn’t work.
I’ve also checked auto copy now, but it’s still the same as before
I tried many times with a campaign author, but it still hasn’t changed
@thieftdp8498

you are probably missing some action. that can be the only explanation i’ve got.