[Modding][Genie Editor]: Increasing techs beyond ID 1455 breaks the game

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: 83607, 85208
  • GAME PLATFORM: Steam
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED

:point_down: DESCRIBE THE ISSUE IN DETAIL (below). LIMIT TO ONE BUG PER THREAD.

When using Advanced Genie Editor to add new Techs, one can only do so up to around id # 1470. Any new entries beyond this id cause the game to break after starting a game with the newly created mod.

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

  1. Create a new modpack with the newest empires2_x2_p1.dat and open it with the latest Genie Editor (v2022.8.21) in the Tools folder
  2. Go to Techs tab and add in new entries up to 1475 and save the file
  3. Launch the game, select the mod with the modified file and start a random map game
  4. Game crashes

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?

Normal game launch without any issues

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.

:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe2spgame) or GAME RECORDING (.aoe2record) of the match where you encountered the issue. Link it below if using an external file service.

Because it is a modding problem, a savegame or recording file wonÄt work. Instead I have linked a modified empires.dat that only includes empty techs additionally to the last patch’s contents.

The hard limit wasn’t a civ limit but a tech limit, then

no problem here

image

2 Likes

I did some further investigating and found out something interesting:

when I copy and paste entries froma another mod, I can indeed start the game, even after hitting the “delicate” id range I mentioned before. But the issue still drops after adding too many more techs, still way below 2000 but around 1500.

@thieftdp8498 what was your exact procedure to test the issue? Have you just copypasted stuff as well or was the screenshot from a public mod? I’d like to know if you (or anybode else) manage to get an empty tech list working as well by building it up from scratch like I did.

Edit: I just included a link to a modded and crashing file to the top post and would be grateful if anyone could try to run it.

im not sure, but I have kept my .dat for a very long time and just kept on editing it. also few patches prior, the official .dat file would crash when i make some changes randomly, 50% of the time which doesn’t make sense. either you crash or you don’t, but it was randomly crashing on start up so it could just be the game or something the devs changed.