Mods don't seem to work

I’m having an issue with mods since the game launched: they are just not working, no matter what I do.

I’ve tested it again with the “2019 Winter Celebration” mod since that’s an official one then I guess at least that one should work but nope. Here’s what I’m doing or rather trying to do on video:

Am I doing something wrong here? What does the exclamation mark mean next to the mod’s title? What does the green checkmark mean? That it finished downloading? Why doesn’t the “open directory” option work? Why does the tooltip tell me this weird ■■■■ about subcribed mods “living” inside Steam directories instead of just telling me the path of the directory where I can find it?

So far the only things I could get working were some custom campaigns. That I managed to do by downloading the files after another user shared them with me and then I just manually copied those files into the “local” folder inside my Windows user directory where Age 2 DE’s mods directory is located. That I can’t do with this mod because:

  • You have to use the broken in-game mod manager instead of MS letting me to just you know, do things the old fashioned way in order to get around bugs like this. Why can’t I just download a mod THROUGH MY BROWSER from the official site?

  • I don’t know where the files are getting downloaded because the game is simply not telling me (that is even if the mod does get downloaded, I mean I can’t check that).

So please, a developer or another user who managed to figure this thing out: help me because I have no clue how this stuff is supposed to work.

Latest version of the game with the December update.

1 Like

Does the mod still have red exclamation mark in “Installed mods” list?

I have heard, that you can subscribe to mod on website and then game automatically downloads it.

Subscribed mods are in “C:\Users{username}\Games\Age of Empires 2 DE{userId}\mods\subscribed” folder (adjacent to “local” folder).

1 Like

“Does the mod still have red exclamation mark in “Installed mods” list?”


“I have heard, that you can subscribe to mod on website and then game automatically downloads it.”

Maybe that’s true if you have the Windows Store / Game Pass verion, it’s certainly not true in my case. What I meant was that I’d love to download the files directly so that I could place them into the local folder and just be done with dealing with their broken mod manager. It’s so baffling that something is not only broken but you can’t even find a workaround because the system itself is terrible design. The Steam Workshop is not fantastic either but at least it works and the platform itself is not closed down (and yeah, I’d like to see Steam workshop support instead of this garbage that refuses to work even after 4 patches because they tried and failed, I gave it a chance, I waited one month so now I’d like to see the thing that actually works and is supported on my chosen platform).

“Subscribed mods are in “C:\Users{username}\Games\Age of Empires 2 DE{userId}\mods\subscribed””

Well there is a directory there for the 2019 Winter thing but it’s only around 80 bytes and the mod manager is telling me that it should be 160 megs. Also: the tooltip is literally telling me that “subscribed mods live inside Steam directories”, whatever those directories are (and I have the Steam version of course).

Anyway is there anyone who’s willing to upload the 2019 Winter mod’s files somewhere (or just provide a direct link if it exists) where I could download them from? I’d like to see the official winter content but MS is not letting me.

@DodoNotDoDo AOE mods page should offer possibility to download mod files directly, without needing to subscribe. Then people could unpack/copy files to local mods folder in case that subscribing don’t work.

Btw, 2019 Winter mod for everyone who have trouble subscribing to it


Just posting to confirm that the mod works now after extracting to the “local” folder from the zip file you provided.

So yep, direct downloads from the website should be enabled at least until the bugs of the mod manager are sorted out.

The problem you have with in game mods is either the game isn’t installed on C: or your user directory id as spaces or unusual symbols, you need to have the game installed on C: and have a simple user directory id so that the game can find the path to your games directory, I fix it today by making a new user

Well, if that’s truly the case then I won’t do that because:

  • Changing your Windows user name is the biggest hassle in the known universe (and something you really shouldn’t do for a videogame).
  • I’m not installing games on my C drive, period.

And if the problem is so simple then why wasn’t this fixed in a month?


That is truly the case and is now clear that is the reason you can’t install mods, and I hope they never ‘fix it’ cause you are annoying

To be fair, I haven’t any weird characters on my username, and I tried to move my game on C: but it isn’t working any better for me.
The game kept redownlading the winter celebration mod everytime I loaded the game trying to fix the issue, making me use 3Gb of data without me noticing.

So I unsuscribed it (like 3 or 4 times) to get rid of it. The in-game mod manager is broken.


Is your user folder name equal to your username?
I had the same problem yesterday and I made a new user in windows and it work perfectly

So for example if my user folder is “Scout” but my username (Windows name or Microsoft account name ?) is “SteppeLancer” it won’t work correctly ?

Wtf? :smiley:

But I’ll annoy you a bit more I guess because the thing is that fixing something like this should be simple. I had an issue like this (caused by my Windows username having one foreign character in it) one time before with an indie game, I reported it and it was fixed in a day.

You know, the only thing the game has to do is grab a zip file from the website and then extract that to your mods directory, it’s a very simple thing. And even if that doesn’t work it’s easy to create a workaround because letting the user to directly download mods from the website would just work for people who are having issues with the mod manager. The functionality is also already there since that’s exactly how Age 1 DE handled custom scenarios and guess what: I never had issues there.

So I’m sorry, I love the game too and have a great deal of respect for the developers because they truly fixed a lot of issues for the December patch but the mod manager still being broken one month after release with none of the easy workaround options applied to it is I dunno, I don’t even get it. I mean they just released limited time official cosmetic content through it, come on.

And as for changing user names, installing the game on your C drive etc.: well, that’s not easy for everyone you know. I don’t have a large C drive because I keep my games and my OS on separate drives so my C drive is a relatively small chunk from my SSD to run the OS and that’s it. Meanwhile changing your Windows username can affect so many things that I’m absolutely scared shitless to do it for a videogame.


It’s possible to have mods work while the game is on your D drive, but the mods are on the C drive. That’s what I have. It’s still annoying that the mods go there, because my C is a rather small SSD that is almost full.


I’m sorry wtf? The guy is trying to solve a problem and all u do is come in and say he’s annoying? The hhell is wrong with u?
The devs f*cked up a simple thing that should have been fixed a long ago, and changing ur username or moving ur whole game to another drive shouldn’t be the only way to fix it. I’ve seen much smaller games never have any issue with this kind of stuff, idk how a huge company like MS can’t do what even indie games did right. His points are damnn right.


Ty a lot for the download link!

What did u do to make it work? My mods are in C as well but it still doesn’t work.

I agree that it’s way too much of an hassle to make a “simple” thing like MODS to work, particularly from a company like Microsoft. You could literally destroy your Windows 10 or have to make a new Windows 10 user for it ? It’s not worth the risk.
They are just mods, but the AoE team advertises it and literally make them for us to be used, instead ofaddind a graphic option for Small Trees for example, or for their Winter Celbration event. I was certain it would be added as a graphic option when they spoke about it in the patch note, but it’s not. It’s a mod everyone is having trouble to get because the mod manager is broken.

I have a guess here that a local user for your win10 may solve some of these issues (may need to reinstall the game, however).

Nothing special. I’m using the Steam version and my Steam library is on D. The game automatically made the folders in C. My windows username has no special characters in it.
If you manually install mods, do they work?

1 Like

I have the exact same setup but it doesn’t work for me, and no even if I manually install it doesn’t work.
The only thing that managed to work for me was something my friend did for me. He can download mods properly, so he downloaded the mods I wanted for him, them zipped the entire mod folder and sent to me. When I unzipped it and replace my entire mod folder THEN it worked.
It feels rly lame that they made a whole christmas mod but didn’t even try to fix the system so people can get the mod to begin with.