Mods don't work

Greetings,

Since the last update none of my mods work, they appear as if always downloading, with the loading circle on the side, but it never ends. Also custom civ mods or data pack mods don’t work either. They throw an error when trying to play a match, with the custom civs it specifically says “An error occured while trying to start the game. The dataset contained an unexpected number of civilizations. It is not compatible with this version of age of empires II: Definitive Edition”. Note that the message is the same, regardless the numer of civilizations on the mod, because I tried with a mod with just a few civilizations and it didn’t work, and the message was the same.

My plataform is steam, I have windows 10 and have already tried reinstalling the game and reinstalling the mods (through the website because in-game ui won’t let me, since it acts as if it is already downloading something) tho none of this has worked. I’d like to know if there’s an issue with my game or is it a general issue that’s being addressed.

Thanks.

The data mod ones break because they were created when the game only had 39 civs. Now with DoI, we have 42 civs, so the data mods and civ mods all break unless the creator updates them.

Thanks for the answer, so that explains it. I’ll just wait for them to update them.
Might you know why my other mods don’t work tho? I really miss smalls trees and those kind of life-quality mods, and my custom maps, because it looks like if the mod engine was broken.

I’m sharing a screenshot I don’t know why I didn’t share before, it won’t even let me unsuscribe to the mods to reinstall them in-game, they just load eternally and none of them work.

No, I’m not sure why they aren’t working, probably file a bug report. If you want to unistall them, you could try opening your mod folder, deleting the mods there, and then going into the text file in that folder, that lists all your mods, and deleting the corresponding mod in that file as well. If you don’t delete the mod in the text doc as well, they will just come back. I can’t guarantee it will work, but it might let you delete them.

Hi there! I have the same problem and I wrote an e-mail to AoE support. Here the reply:
“Thank you for your message and for your report. Currently this is a known issue, and our Team is working on a fix. Please keep checking frequently for updates.”
I asked them also how long it was going to take and they wrote me back:
“As you know we are constantly releasing updates. I don’t think that it will take much longer, currently our Team is working on it.”
This exchange is dated May 5th. I hope they are releasing a fix in the next days.

The bug report you mention is the same as reporting a bug here on the forums or is something different like in-game bug report? Also, any news on this topic? Will it be fixed in today’s mantainance?

I have the same problem…

Hi @CapitanPetit !

We are aware that some players cannot install mods, thanks ^^

I have this issue since I bought Indian Dynasties, because my friends that don’t bought it can still use mods without any problem. To be honest 95% of my gaming experience in AOE2 DE was around mods, either with custom civs or custom maps with my friends. Because of this I’ve lost much more than I have gained, and I feel cheated, like if I had payed to downgrade my game. I like the dlc a lot, it’s just I miss to be able to play with my friends the way we used to. If you can’t fix the problem I’d like my money and dlc back so I can return to the version of the game that wasn’t broken, then maybe purchase it again when you fix it. But for now, this has totally ruined my AOE experience and has got me very dissapointed… specially for the late replies.