Mods fail to update "no download url available"

:arrow_forward: GAME INFORMATION

  • BUILD #: latest build
  • PLATFORM: Steam
  • OS: Windows 10

:arrow_forward: ISSUE EXPERIENCED

:question: DESCRIBE THE ISSUE IN DETAIL (below). Limit to ONE issue per thread.

Here is the problem I’m experiencing…

:arrow_forward: FREQUENCY OF ISSUE

all update attempt failed

:arrow_forward: REPRODUCTION STEPS

Here’s the steps to reproduce the issue:

  1. attempt to update the mod
  2. let it load and fail
  3. error message showing “no download url available”…?

@DodoNotDoDo please help. I’ve been trying for last 2 hours and still getting the same error message. been checking on forum/news and I don’t see any maintenance

1 Like

I have the same problem i coudn’t upload any mods…

I cant choose a File from the Mod-Folder.

1 Like

It looks like yours finally went through. If that’s not the case let me know. I’m in the process of updating to a new backend that will hopefully be more reliable in publishing successfully.

1 Like

I don’t see a mod submission from you. Based on your note it sounds like it might be a problem in the game client before even submitting. If so, if you can create a new thread with more detail we can investigate.

My mod is actualy only private and i uploaded it via the website, becouse i can’t upload it in the game its also bugged if i click on import lokal mod…

I think it won’t import correctly because it’s not set up correctly as far as file/folder structure. It’s just the scenario file. Try subscribing to another scenario and check out how they have it set up and replicate that.

Ok now it looks like correct. But if i want to update it, i still can’t choose the right Folder.

That should be selected automatically based on the title of the mod. If you have an info.json file in your mod folder you should be able to specify it using the Title property.

1 Like

mine hasn’t gone through yet, let me try again.

@DodoNotDoDo i am still getting the same error no download url available.

it lets me upload as a brand new mod but not update an existing old mod, do you know what is causing this?

Yours appears stuck. I’m investigating…

1 Like

thanks a lot man! 20 char

Somehow your mod ended up with something like 15 images associated with it so it hit an internal limit and got stuck. I’m assuming that wasn’t intentional on your end since most of them were duplicates. Someone just pointed out another mod with a similar situation so I’m guessing there’s a bug somewhere causing the image duplication. Were you mostly trying to publish from in game or on the web site?

I’m going to see if I can remove the dupes and push it through. I’ll let you know if I succeed and/or when it’s clear to try updating again.

1 Like

i try to publish mod in game, but i did encounter bug through website it does not let me remove image. after i remove them and click submit, nothing loads and saves. so this is probably cause the issue. could you help me manually remove all the image so I can update ?

edit: i will check now, thank you!

@DodoNotDoDo ok just tried to edit via website to remove pictures but it wont let me, running into the same problem from few days ago. I think each time we update the picture duplicates thus increasing picture count.

is it possible for you to help me manually remove them? I tried both firefox and chrome, with and without any extension and still wont allow me to remove picture and save them.

I checked with the folks that manage the part of the pipeline that it’s stuck in and they have to implement a fix to get it working again at this point. Hopefully that will happen tomorrow.

1 Like

alright thanks for checking into it man hope to hear good news soon

At long last it looks like the fix is in. If you continue to have a problem updating, let me know. And thanks for your patience!

1 Like

will try it right now, thanks for the update!

@DodoNotDoDo it is workign now. thanks so much man you are amazing always ontop of it!

I can even remove the pictures from website now.

1 Like