Mods not working

Game Version:

  • Build (101.101.34223.0)
  • Platform (Steam)


I can not enable mods in Installed mods

Reproduction Steps:

  • I browse for mods
  • I subscribe it and wait till downloaded
  • I can not enable mods because there are red exclamation marks

I am unable to reproduce this issue, what language are you running your system in?

1 Like

i have the same issue too

Build (101.101.34223.0 4509956)
Platform (Steam)

and i have the folders for 2019 winter celebration mod but folders are empty


I use system with czech language

I have a similar problem but on MS platform (got the game with Game Pass)
All the mods I subscribed have an exclamation mark or a cog icon and they doesn’t work. (Just got answers on a reddit post, the cogs one are because they’re data mod. I didn’t know that)

Game build : 101.101.34223.0 0
Windows 10 build : 1909 (18363.535)
My game is installed on a G: SSD and the mods are on C: SSD (in the User/Games/AoE2 DE folder)
Mods’ foldedr are not empty, but guess there is something missing.

I looked at some files into the Game folder
In the mod-status.json file, the PublishID of ALL the mods is 0 (that’s weird if it’s an ID, I guess)
The checksum for the mod that have an exclamation marks is 0 (really weird too).
Others values seems fine.

The info.json in eachj of mod’s folder seems fine.

Hope that can help a bit

1 Like

Same issue here. I hope we can fix that soon :confused:

1 Like

I have completely same problem!

anyone can help about this please? this is very annoying


Hello friends! I have a few troubleshooting steps you can try and report back to see whether they work for you. We are tracking this issue and will be digging into the problem as we collect more information about it:

  1. Follow the steps in this article to see if any of them address the issue:
  2. Make sure you are signed in with the correct Xbox Live Account. If you have multiple Microsoft accounts, Windows may log you in with a different account than the one tied to your free XBL account. Make sure you log in using the correct account with an Xbox Live profile [ ].
  3. Make sure you are signed into the Xbox Companion Console. It should come standard with Windows 10. If you’ve uninstalled it, make sure you re-download and sign into the app before launching your game.
  4. Exit and re-start Steam to make sure you are on the latest build. If you haven’t re-launched Steam in a while, give it a shot and try again.
  5. Verify the integrity of your game files. It shouldn’t take long, and will catch any errors in your game’s installation.

If any (or none) of these steps work, please let us know which worked/which you tried so we can continue working to troubleshoot this problem.

Thanks, everyone!

I have the same roblem, need help pls

Thanks everyone for posting about this. We are currently investigating the mods displaying a red ! and failing to download. It’s been added to our Known Issues list here:

Age of Empires II: DE Known Issues

1 Like

finally… hope this’ll fix ASAP. tried everything but still nothing :frowning:

Hey everyone! Can you confirm if this is working for you now after patch 34699?

YES !!!
Finally working
Thank you

1 Like