Mongol campaign Blockade at Lumen Shan

Mongol campain Blockade at Lumen Shan. During the campain when you are defending against the waves of enemy the 8th wave will not spawn. I’ve reloded and restarted my game and tried that mission several times but the 8th wave never seems to spawn.


I had this issue today as well except 6/8 waves spawned and the final two waves did not spawn after several minutes. Guess I’ll restart.

For missions like this there should be an alternate victory condition so that players can finish it if something goes wrong.


Its definitely a bug, but its an enemy AI pathing thing. I bet if you scouted the riverbank of that South part of the map, you’d find a whole bunch of enemy units camping out of the shore, doing nothing, like this:


I have played this campaign and this mission seems to be quite frustrating and boring.

Hi @Sentenal, Since I had a lot of free time in the mission, I went searching for any enemy AI but could not find them.

The “out of bounds” towers in the north can attack you but you can’t attack them.

1 Like

Have you tried to see if any have gotten stuck in the tree lines to the south? There are a couple empty pockets in the forest that maybe they could have gotten stalled in

Yes. Just played through this again and retraced the enemy paths and surrounding areas leading up to my stone walls.

Gameplay video below of the bug where I was able to reproduce for the 2nd time.

1 Like

Well damn, makes me glad I haven’t played the campaign yet. Guess I will continue to hold off until Relic completely fumigates the game of bugs. At this rate, they might need to deploy DDT.

Hi @KettleBunny, The only campaign mission I was unable to complete due to a bug was the 2nd to last Mongol campaign, so don’t let this one bug stop you from playing the campaigns!

Ah ok, I was worried since I was following most of the bug reports and there are quite a few faction bugs which well… bug me. However if the rest of the campaigns are playable, I will give them a go. Might even inspire me to play medieval 2 once I finish them.

So you are sure that if you run up to the riverbank that your cavalry pass at 32:03 does not have the enemies at it? As in, send your units up to the river as if you are trying to make them go into the water, and then walk down the very edge of the river. If they are where they were for me, you can’t see them from the path your cavalry took in the video.

They were here for me:


I will play the campaign mission again and look there but fact of the matter is the enemy waves of units should not get hung up on the terrain requiring that I send a search party. There was no problem with the previous waves reaching their destination.

Apologies you are all running into this. I’ve reported this to the team so it can be checked out. Thank you for the bug reports!

Oh, I completely agree. If you see my earlier screenshot, I looked around for the missing waves for literally an hour and a half, even going so far as to chop down most of the trees on the south side of the map. Just trying to help you find them so you can complete the mission!

This is definitely bugged. I eventually found the units that had pathed and got stuck. They were in a place that couldn’t be attacked so I had to restart mission. Please fix.

As a work-around until the bug is fixed, build your walls in a similar position shown in the Ornlu video below and do not destroy any bridges. Particularly destroying the long bridge in the southwest of the map appears to create issues with the waves of units that spawn and attack your defenses.

Well… I’ve built my walls, a lot of elite horse man keep respawning and attacking (like before starting the waves) but it gets stuck there.

There are no hidden soldiers anywhere (I’ve built a lot of outposts to make sure) and the real waves never start coming :frowning_face:

Hiya, this appears to still be a thing as its something I have now encountered. I researched it already and went off searching the lanes myself, even put up towers everywhere trying to spot every nook and cranny. Nothing. Is there any confirmation this is even being looked at? I see none anywhere in the known issues or update threads. This break does not allow us to continue the compaighn…at least not without restarting and doing some sort of sneak trick to manipulate the bug. Which I really have no interest in starting over again.

Thanks @vergil18! We’re working on it but do appreciate the report.

1 Like