Mongols AI - Tuning Pack & Stone Deposit value changes

Issue description:
Creating Tuning Pack where you edit “resource_deposit_ext\initial_amount” values of “resource_stone_deposit” and “resource_stone_deposit_small” in “attributes:ebps\gameplay\resources\stone” cause issues with Mongols AI not building Ovoo which results in that AI will not do anything whole game except AI using Khan to scout map (without using Tuning Pack Mongols AI work as intended, they start building Ovoo, unpacking Town Center & Ger).

Gameplay of Mongols AI with Tuning Pack - with changed “resource_deposit_ext\initial_amount”:
Using_Tuning_Pack_with_stone_deposit_changes.mp4

epbs-gameplay-resources-stone-resource_stone_deposit_small.jpg
Changed: 1200 → 4800 (this value can be lower than original and AI will work, not sure what is max amount when AI will start to be broken)

epbs-gameplay-resources-stone-resource_stone_deposit.jpg
Changed: 2400 → 9600 (this value can be lower than original and AI will work, not sure what is max amount when AI will start to be broken)

Gameplay of Mongols AI with Tuning Pack - without changed “resource_deposit_ext\initial_amount”:
Using_Tuning_Pack_without_stone_deposit_changes.mp4

How to reproduce this AI “malfunction”:

  1. Create Tuning Pack using Essence Editor
  2. Select attributes and choose Ebps
  3. Clone “gameplay\resources\stone\resource_stone_deposit”
  4. Clone “gameplay\resources\stone\resource_stone_deposit_small”
  5. Change “resource_deposit_ext\initial_amount” of “gameplay\resources\stone\resource_stone_deposit” to 9600
  6. Change “resource_deposit_ext\initial_amount” of “gameplay\resources\stone\resource_stone_deposit” to 4800
  7. Build Mod
  8. Create game using this Tuning Pack

Possibility of forgetting to edit something in Essence Editor?

  • Can this issue be caused by something that need to be changed also when editing “resource_deposit_ext\initial_amount” of “gameplay\resources\stone\resource_stone_deposit” to work properly with Mongols AI?
1 Like

Really appreciate the well written bug report @Wruktarr. We’ll investigate this!

1 Like