Monks don't heal automatically

  • GAME BUILD #: 101.102.18071.0 (#83607) 0
  • GAME PLATFORM: Microsoft Store
  • OPERATING SYSTEM: Windows 10

:arrow_forward: Monks don’t automatically heal hurt units

After big update this morning, my Monks were just standing around while units around them got hurt. I could order them to heal, but when they were done they would stop, eben if the same unit got hurt again.

:arrow_forward: FREQUENCY OF ISSUE

  • 100% of the time / matches I play (ALWAYS)

Here’s the steps to reproduce the issue:

  1. make a monk
  2. make some soldier
  3. hurt the soldier

:arrow_forward: EXPECTED RESULT

:point_down: monk heals soldier


Hello @sirlutely
I tested this issue on the scenario editor but couldn’t reproduce, could you send me an scenario or a rec where this issue occurs?
Thanks for your report!

1 Like

I have encountered this today, too.

1 Like

Thanks a lot for replying! Well, i found the rec and tried to upload it: “Sorry, new users can not upload attachments.” That’s convenient :(. I watched the replay again and noticed: The monks first healed a villager and some archers automatically, a bit later they did not react on hurt villagers or knights. I tried to ‘activate’ them by tasking them to heal a knight, they healed him, but did not proceed to heal the rest.

I’ll create a very small ai game and test the same thing again, let’s see.


Exactly the same for me. The monks started off healing ok but then just stopped healing anyone without prodding after about 15 mins of playing. Not sure if it’s related, but all unit animations stopped, too, so everyone was just ‘skating’ across the map.


the same happened tome. The monks started healing as usual but then just stopped healing anyone

1 Like

Thank you! I’m not sure if you can post a link here, but you can use to send the file :slight_smile:

1 Like

I’m not sure how relevant this is, but this particular savegame when reloaded always has non-healing monks (and skating units), whereas new games work fine.

I was playing the Sforza campaign, scenario 2. The monk that spawns at the start of the scenario would heal automatically. When he was killed, I trained new monks. They would heal troops trained in military buildings, but they would not heal the Gaia troops that I’d collected earlier in the match unless prompted to do so.

Ok, i have a new game where the monks stopped healing, the file is on Gofile - Free Unlimited File Sharing and Storage
You can ignore almost all the game up to the last three minutes: The monks on the southern army stopped healing automatically, though work fine if i order them to heal. Those in the northern army still heal normally. Maybe you can even load that game and play, maybe the bug will still be there.

Edit: I reloaded and played this one, but the bug was gone. I also noticed that i cannot use this as a replay, so it is useless to you?


Ok, i managed to creata a rec file where the same happened, several minutes towards the end there are monks standing around some hurt knights not doing their job, same folder: Gofile - Free Unlimited File Sharing and Storage


Hello, does anyone have any update on monk-not-healing-automatically bug? I wonder when the developers are going to find X the bug? :slight_smile:

This issue has been driving me mad. For me monks still work fine with the default data set, but any modding of healing range, even if its still well within their search radius, creates this apathy. They even start fine but give up after a few minutes, making it such a pain to test.

For anyone interested, mod their healing range and you will reproduce the issue every single game.

Hmm, i don’t mod my healing range, actuall i use very few mods, sometimes the small trees. Still it happens every single game. Sometimes the same group of monks starts working fine again, i have no idea why though.


I’ve had monks that starting working again because a castle was built next to them, or because I changed formations, or a different group of units came in.

This bug is so random… :S

1 Like

The bug is still there, i learned something though: If the monks get stuck, i need to move every single one of them separately, and they work normally again. This reminds me of another bug i had recently: I box an army (i always do, i never use keys to select a group) and try to move them, but there are trebuchets in that group, which are not able to move. Some weeks ago the whole army would have moved weirdly, not knowing what to do. That doesn’t happen any more, but now it sometimes happens that either the trebuchets or the monks can’t move as a group. If i try to move several at a time they just won’t budge. Solution is the same: i need to select every single one and move them, afterwards they behave normally.
That means: The inability of the monks to heal might be imposed by ‘belonging to a group’ and experiencing limitations because of that. Such a code might be needed to make an army move properly, f.e. a bit slower than the slowest member and holding a formation. Fixing would be simple, but might still be hard to do: It seems that group members remember their limitations after the group has stpped moving. They need to forget all limitations as soon as they arrived at their destination.

Hope that helps…


And today, moving the monks one by one did nothing :frowning:

1 Like

This is another issue the team is tracking as well.

Yeah i noticed the bug too. The monk were not auto healing injured units as intended.

1 Like