Mouse Cursor disappearing when clicking various menus (Borderless Fullscreen)

[Game Version]
Summing it up as concisely as possible, I have been consistently encountering (for weeks now) that my mouse cursor will disappear in-game (not cease to function, as I still see it highlighting the menus in-game and I’m able to navigate through them as you normally should) when I go into different parts of the game.

[Info on Reproducing Error:]
Be it clicking on the Masteries tab, Single Player to enter the screen where I can decide to either do Campaign or Skirmishes, checking Civ’s tech trees, or even by double clicking the tabs at the top labeled “Play,” “Community,” “Learn,” and “Mods,” my cursor will disappear (and sometimes I’m lucky and it won’t but more often than not, it does disappear), only to be brought back by simply Alt-Tabbing out of the window and back in.

[Temporary fix: Alt-Tabbing out & back in:]
This wouldn’t be nearly as much of an issue for me personally if it wasn’t happening multiple times in the span of minutes while I’m just trying to look through some ish in-game & set-up a game. I will Alt-Tab back in, and in continuing what I was trying to do it’ll vanish again, creating a frustrating loop of events.

This issue primarily pertains to the menus in-game, however upon starting a Skirmish where you’ll press “Any Key to Start,” that also is a trigger for the cursor to disappear (terrible timing might I add, as you’re just entering the game and wanting to get your vills and TC going).

[Other online articles in this lane are irrelevant to my particular issue, sadly:]
All online questions regarding this issue all point to your device settings for your mouse, and making sure you have pointer trails turned off and that you can still see your cursor while typing. These settings are set as they should, and they problem still unfortunately persists.

Apologies for bringing this up but I find no other article nor source of long-term remedy for this situation, as Alt-Tabbing evidently can only do so much to alleviate this. Thanks for enough concern to read this, and hopefully this can start to shed light and get this small QoL bug to be fixed.

–Photo & Video Evidence–
[TL;DR: Gyazo wasn’t the move, and there’s the screenshot of my invisible cursor]
In an attempt to show you a replay of what it looks like on my end, the Gyazo recording window seemingly prevents the issue from occurring. The downside is that the window lasts for all of 7-8 seconds (as the program is meant to only record videos up to that duration), so after 8 seconds it’s back on where it can be gone at any time.

In lieu of actual solid video evidence, here’s a Before & After screenshot, where I’ll have the cursor hovering over the “Play” menu tab (while in Community) and I will double click it, and the After will show my invisible cursor hovering over the much larger & easier to see “Single Player” tab so you can clearly see even though the button’s outlined like my cursor’s on it, it’s still invis.

Screenshot 1: Am New User, so I can only embed a single piece of media into this forum post instead of being able to include 2.
Screenshot 2:

(Aaaaand it’s gone, even though you see the Campaign and Single Player highlighted.)

Sorry you’re seeing this @AsmodeusIX27! Best thing to do would be to first update all your drivers. If that doesn’t work, please contact support with your DxDiag and warnings.log file. Thanks!

1 Like

Sounds good. In this instance, I unfortunately do have all the up-to-date drivers for my device (mouse) and for anything DirectX related or GPU related (Radeon Software for me personally since I have an AMD GPU).

I’ll see if I can send them my DxDiag and warnings.log file. I’ll report back if and when I find any form of success or update.

1 Like

I’m seeing precisely the same issue. Also running on a AMD GPU with latest drivers installed.

1 Like

Bought the game 1 week ago. Issue happening since January and still no answer for that? What’s happening? It’s barely unplayable in that state. Any popup from missions, boxes, infos… the cursor goes MIA. Only fix is the alt+tab thing.

Same situation as Asmodeus. All drivers updated, high end machine. Using a 6900xt with latest drivers, borderless window mode.


Same issue here, started happening after windows 11. Tried disabling “Optimisations for windowed games” and didn’t help. Anyone have any updates?

Also 6800xt.

This is still the best course of action if you see this happening. Unfortunately there’s been very few reports of this one so the more of you that can supply us with a DxDiag, the better.

I had the same issue with an AMD RX 6500 XT and an RX 6650 XT with up to date drivers on Windows 11.
The fix for me was to disable “Radeon Enhanced Sync” in the AMD Software for AoE. (I use a FreeSync compatible monitor.)

Other workaround for me was to just install old graphics drivers (from around mid 2022).

Hope that helps someone else.

Thank you. Really appreciate that you helped me finally find the culprit